PHP Timezone

I get this warning in WHMCS and also cron runs at a different time than my local time.

“our PHP environment does not have a valid timezone setting. Please set date.timezone in php.ini to ensure correct date and time processing. If date.timezone is set in php.ini and this warning is still shown, please check the spelling of the timezone identifier. Please refer to our documentation for more information.”

I already set the timezone on the server to Asia/Karachi using timedatectl, tried adding php.ini and change it by PHP Comfigs > Advanced, and added Asia/Karachi as timezone.
But it is still not working. When I check via phpinfo it says Default Timezone is UTC.

I am using PHP 7.3
Any help about setting it as Asia/Karachi?

Thank you

Not certain if this is still an issue for you, I just moved a WHMCS install to CyberPanel and had similar issue, but changed as you suggested in the php.ini file using the advanced tab in cyberpanel then restarted the php (note to select the same php you assigned to the site) and the issue appears to be resolved.

Still working on some other issues as my cron jobs do not want to be outside the public_html folder which is not the best for security.