PHP reverts to 7.1 and overwrites lsphp74 to 7.1 on upgrade

Hi everyone

I upgraded cyberpanel using the upgrade script (minor 2.3 build 2 commit upgrade), but after the upgrade I noticed that CLI php reverted to 7.1 (it was on 7.4).

I also noticed that /usr/bin/php was a symbolic link to /usr/local/lsws/lsphp74/bin so trying to do “/usr/local/lsws/lsphp74/bin -v” also showed me php 7.1 installed. So I believe that the upgrade somehow replaced lsphp74 with a 7.1 binary.

The solution was to reinstall lsphp74 with dnf reinstall and the situation was solved.

To make sure it was the upgrade that caused that, I ran the upgrade again and replicated the issue.

VERSION=“8.6 (Sky Tiger)”

I’m attaching some screenshots.

1 Like

I am facing the same issue, After upgrate lsphp73 & lsphp74 is php7.2 in actual, please guide ho to reinstall

Ii’ve already opened a bug report of this issue and they are aware of it.
I may be fixed in the next version hopefully.

Php reports incorrect version - CyberPanel Project / Bug Report - CyberPanel Community