PHP Error with all Versions: Fatal error: Out of memory (allocated 4194304) (tried to allocate 20480 bytes)

Hello all,

we are currently getting permanent “Fatal error: Out of memory (allocated 4194304) (tried to allocate 20480 bytes)” errors and this with versions 7.3, 7.4 and 8.0. We can’t help ourselves anymore, because we could limit the error so far only to the variable “memory_limit” within the “/usr/local/lsws/lsphpXX/etc/php.ini”. We have already tried the most different values. Currently 2048M is set.

Can you help us in somehow?

have you confirmed the version of php being used by end users and also confirmed the php version being used by root?

I’m not going to say that I have your solution, but I can say that I was surprised when I found the version of php that root was using (much older).

when updating the php symlink in /lsws to a more recent version, the issue went away for me. alternatively, updating the memory limit used the default root php version worked for me.

alas… there’s always the chance that I’m 100% misunderstanding your issue. but, no harm in trying, yes?