PHP 8.2 issues - I cant use PHP 8.2 on Cyberpanel. HELP

Even though with the latest update PHP version 8.2 is installed, I still can’t use it. This is very detrimental because I have to move my projects to servers other than cyberpanel. PHP Switcher shows me 8.2 but not the options, and my site shows me “Composer has detected problems in your platform: your Composer dependencies require a PHP version “>= 8.2.0”.”

I really need help. Thanks. Regards

1 Like

I have the same problem too.
Error: cat: /usr/local/lsws/lsphp82/etc/php/8.2/litespeed/php.ini: No such file or directory

Current Version: 2.3
Build: 4
Current Commit: c8da443334b8815ec250a0fba606e75355f641cd
Ubuntu 20.04

I can’t imagine no one from Cyberpanel responding for this bug!!! On the panel there is PHP 8.2 but impossible to use it and when you ask the question.


apt-get install lsphp82*
1 Like

Thanks Usman.

Hi usman,
i tried to insall but my problem remain the same: Your Composer dependencies require a PHP version “>= 8.2.0”

help please: how install dependencies require a PHP version 8.2.0.

8.2 should work fine in 2.3.5 now.

1 Like

Yes, im realy happy for that

I ask you to explain - how to make (which command) so that my system (Ubuntu 22.04.3) considers php 82 as the system stack?

Upgrading cyberpanel 2.3.5 should add 8.2 to your panel automatically.


sh <(curl || wget -O -

1 Like

After upgrading Cyberpanel to the latest commit 2.3.5 I still can’t see any PHP 8 versions in the panel. Only PHP 7.2, 7.3, 7.4 available to choose.
My OS is Ubuntu 20.04.6 LTS (GNU/Linux 5.4.0-171-generic x86_64).

What can be an issue here?

And another quick question - should I upgrade my server to Ubuntu 22.04.3 LTS? Will it break current Cyberpanel install?

Thanks in advance for any help!

in this version, ubuntu - 82 appeared only after forced installation via the command line and not through the panel

1 Like

If you want to install all php versions try this command

apt-get -y install lsphp8*
1 Like

Hi! Thanks for you response. But I only need 8.1 version as Wordpress support is out of Beta for 8.1 and compatible with some minor exceptions.

Should I make any OpenLitespeed config changes after I install 8.1? Or it should work out of the box now?

then do

apt-get -y install lsphp81*
1 Like

Thanks! Done! Now I can see 8.1 PHP version.

And another quick question - should I upgrade Ubuntu from 20.04.6 to 22.04.3 LTS? Will it break my current Cyberpanel install? Which safe command to use to upgrade it?

Thanks in advance for any help!

Not safe, don’t do this.

Rather get a new Ubuntu 22 server and transfer the sites.

1 Like

Installation failed. Error message: ["sh: 1: /usr/local/lsws/lsphp82/bin/php: not found"," [404]"]