PHP 8.2 in CyberPanel

PHP 8.3 released but CyberPanel is still on PHP8.1 :neutral_face:. When we get latest php8.2 and 8.3?

let me have a look.

Ref: dynamically detect php version in ref to: https://community.cyberpane… · usmannasir/cyberpanel@6a4e63b · GitHub

CyberPanel will now detect installed PHP versions dynamically. It seems PHP 8.3 is still not available in LiteSpeed repos, so you can’t use that for now.

But if any other version is not shown there, just do

apt-get install lsphp82 for PHP 8.2 or to install with all extensions apt-get install lsphp82*

For Redhat based

dnf install lsphp82 for PHP 8.2 or to install with all extensions dnf install lsphp82*

So when the PHP version is available on the OS, it will be shown on CyberPanel.


I meant to say for PHP8.2. PHP83 is juat released so not available on LSAPI.

Upgrade CyberPanel, and do what I said above, it should be avaiable then.


If I switch to PHP 8.1 or PHP 8.2, the server returns error 403. Fix permission does not help. :confused: I use wordpress.

Interesting I had the same issue when I restored an existing backup. Did you do a fresh install of WP or restore from backup?

I haven’t backed up once. I didn’t even do a clean install.

Sorry, misread your post, your asking about changing PHP version on an existing site. I will have to let someone else pitch in here with any ideas.

I have a similar problem with PHP 8.2, cyberpanel already offers version 8.2 to upgrade to version 2.3.5, but it doesn’t work. I looked at the litespeed administration on port 7080 and in litespeed version 8.2 is not defined …
(sorry for the machine translation)

I just tried a fresh install of WP via CP website install on:

Current Version: 2.3 Build:4
Current Commit:
Ubuntu 22.04

I tried changing the PHP vs via the CP website settings page. Selecting 8.2 accepts but doesn’t change the actual version. Any other PHP vs changes to what is selected. I checked this with vhost PHP vs and phpinfo.php.

OpenLiteSpeed or enterprise? Also what is output of

ls -la /usr/local/lsws/lsphp82/bin


ls -la /usr/local/lsws/lsphp82/bin
total 88
drwxr-xr-x 2 root root 4096 Jan 22 10:26 .
drwxr-xr-x 8 root root 4096 Jan 22 10:24 …
-rwxr-xr-x 1 root root 5105 Dec 22 11:58 php-config
-rwxr-xr-x 1 root root 5105 Dec 22 11:58 php-config8.2
-rwxr-xr-x 1 root root 7368 Dec 20 2022 phpdismod
-rwxr-xr-x 1 root root 7368 Dec 22 11:58 phpenmod
-rwxr-xr-x 1 root root 4757 Dec 22 11:58 php-helper
-rwxr-xr-x 1 root root 4571 Dec 22 11:58 phpize
-rwxr-xr-x 1 root root 4571 Dec 22 11:58 phpize8.2
-rwxr-xr-x 1 root root 9778 Dec 22 11:58 php-maintscript-helper
-rwxr-xr-x 1 root root 6382 Dec 22 11:58 phpquery
-rwxr-xr-x 1 root root 2841 Dec 22 11:58 sessionclean

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.

OK, So problem is I don’t see the php and lsphp file.

Remove and re-install lsphp82

apt-get purge lsphp82*
apt-get install lsphp82*