outgoing mail error

my setup is vultr with centos 7 & cloud flare as a cdn, i put MX on cloudflare, but the strange is my incoming mail is fine (from gmail to mymail) but when i try outgoing it’s just nothing, i check the log and find the issue below, is there any setting that must rbe equired or maybe my setup is a problem ?

Jul 18 09:56:57 guest dovecot: imap(order@cetakqu.com): Disconnected: Logged out in=96 out=867
Jul 18 09:57:13 guest postfix/qmgr[15063]: 87E6A76B8: from=order@cetakqu.com, size=1208, nrcpt=1 (queue active)
Jul 18 09:57:13 guest postfix/smtp[18872]: connect to gmail-smtp-in.l.google.com[2404:6800:4003:c02::1b]:25: Network is unreachable
Jul 18 09:57:23 guest postfix/smtp[18855]: connect to alt1.gmail-smtp-in.l.google.com[74.125.195.27]:25: Connection timed out
Jul 18 09:57:23 guest postfix/smtp[18855]: connect to alt1.gmail-smtp-in.l.google.com[2607:f8b0:400e:c09::1a]:25: Network is unreachable
Jul 18 09:57:27 guest postfix/smtp[18869]: connect to gmail-smtp-in.l.google.com[172.217.194.27]:25: Connection timed out
Jul 18 09:57:27 guest postfix/smtp[18869]: connect to gmail-smtp-in.l.google.com[2404:6800:4003:c02::1b]:25: Network is unreachable
Jul 18 09:57:43 guest postfix/smtp[18872]: connect to gmail-smtp-in.l.google.com[74.125.24.27]:25: Connection timed out
Jul 18 09:57:43 guest postfix/smtp[18872]: connect to alt1.gmail-smtp-in.l.google.com[2607:f8b0:400e:c09::1a]:25: Network is unreachable
Jul 18 09:57:50 guest dovecot: imap-login: Login: user=order@cetakqu.com, method=PLAIN, rip=::1, lip=::1, mpid=18874, TLS, session=

Vultr block port 25 for new accounts, confirm with them if they can open port 25 for you.

thanks, my port already open but again i had one minor problem, all my ongoing email getting in to spam folder (menu) at gmail or yahoo, how can i retrieve this problem ?, thanks again…

Sending an email to the inbox is kind of an art these days. First read this guide: Achieve 10/10 Email score with CyberPanel! - CyberPanel

And then report your mail score, even you achieve 10/10 email score it may take time until your emails start ending up in the inbox, but its a good start.

hi again sir, thanks my web mail fully worked now, but when i test the mail only gets 5.8/10, i’ve already follow step by step setting on that blogs but when i test i got “We didn’t find a server (A Record) behind your hostname server.example.com.”, when i check again with super tools (that your blog recomended) my ip address (server) not match with domain (it’s write xxxxx.vultr.com), is there something wrong with it ? or i miss the step, thanks for your advice…

You need to setup RDNS and hostname for the mail server. Go to: 2 - SSL For PostFix/Dovecot - CyberPanel

For example, you choose to issue mail server SSL for domain.com, then set RDNS of your IP to domain.com

https://www.vultr.com/docs/how-to-create-reverse-dns-or-ptr-records-in-the-vultr-control-panel

my provider is GCP but they cannot open 25 port, what can I do