Options +FollowSymLinks, ports 25 465 & 587

Hello, I installed OpenLiteSpeed with CyberPanel and I need to add
Options +FollowSymLinks
in .htaccess to change the prettyurls of every WordPress site.
I have also an issue with mails port 25 and 587 are connected with example.com and 465 can’t connect to localhost.
Can anybody help me please ?

It does not send any mail with a simple php script.

Hi, could you be a little more specific about 465 port ?

for symlink ,

  1. follow this to be able to access to webadmin console https://forums.cyberpanel.net/discussion/87/tutorial-how-to-setup-and-login-to-openlitespeed-webadmin-console#latest
  2. As screenshots indicates , go to virtual hosts , your-domain , basic

All domains follow their symlinks.
I tried to remove the Options +FollowSymLinks and still it follows. It seems ok now.

About ports I can’t send any mail from any site.
I am trying to understand why with a WP plugin named Post SMTP.
I try my Internet Provider’s SMTP and my registar’s SMTP but all fails to connect to the right server.
Ports seems like this :

Before sending email from a php script, run following on CLI

journalctl -f | grep postfix

After sending paste the output from command line.

I received this email “4.7.1 : Relay access denied”

Can you please email all related login information to : support [@] cyberpanel [dot] net

Or join our discord channel from top right corner, also mention the steps to reproduce the problem.

Regards

postfix/anvil[2070]: statistics: max connection rate 1/60s for (smtp:80.82.70.210)

postfix/anvil[2070]: statistics: max connection count 1 for (smtp:80.82.70.210)

postfix/anvil[2070]: statistics: max cache size 1

from=uprfr@server.example.com, size=380, nrcpt=1 (queue active)

host mx1.mail.ovh.net[188.165.36.237] said: 450 4.1.8 uprfr@server.example.com:

Sender address rejected: Domain not found (in reply to RCPT TO command)
96C5BD80847: to=postmaster@alpha-top-depart.com, relay=mx2.mail.ovh.net[87.98.160.167]:25, delay=4779, delays=4772/0.06/6.7/0.34, dsn=4.1.8, status=deferred (host mx2.mail.ovh.net[87.98.160.167] said: 450 4.1.8

uprfr@server.example.com: Sender address rejected: Domain not found (in reply to RCPT TO command))

Hello,

Test this:

Edit /etc/postfix/main.cf … line ~681 “myhostname” and change server.example.com with your domain. Then restart postfix ( service postfix restart).

Can you tell us the name of the WP plugin too?

This plugin is Post SMTP. https://postmansmtp.com/
Changing “myhostname” like this is working! I have put my smtp provider and it works.
My sites can send email now.
Solved.

Another issue with SymLink. I created a subdomain with path to root. I checked :

Follow Symbolic Link	Yes

But the subdomain site (in Wordpress multisite configuration) does not follow the symlinks. It works only in basic Wordpress linking system. The main domain works.

I also have enabled Wordpress multisite for another domain with sub directory. It show a page with almost nothing : no css pictures, etc. because of Failed to load resource: the server responded with a status of 404 () The main domain works.

You need to update rewrite rules for WordPress multisite to work:

Subfolder : The trailing slash is OK. HTTPS is OK too. wp-admin has ERR_TOO_MANY_REDIRECTS
Subdomain : no change. Can NOT do prettyUrl only in subdomain.
I also did as mentioned here htaccess « WordPress Codex

Submit with complete details to: Home - CyberPanel

if i enabled follow symlink , shall i edit .htaccess?

@romain said:
Another issue with SymLink. I created a subdomain with path to root. I checked :

Follow Symbolic Link	Yes

But the subdomain site (in Wordpress multisite configuration) does not follow the symlinks. It works only in basic Wordpress linking system. The main domain works.

I also have enabled Wordpress multisite for another domain with sub directory. It show a page with almost nothing : no css pictures, etc. because of Failed to load resource: the server responded with a status of 404 () The main domain works.

what do you mean “basic WP linking system” ?

what exactly are you want to archive ?

@moataz said:
if i enabled follow symlink , shall i edit .htaccess?

No really , if you enable it in webadmin console .

actually , in .htaccess , any content that is not rewrite rule , OLS just will ignore it as it doesn’t understand it