Opening new ports not working


I have been trying to install an Ark server using docker-compose on the machine. When coming to the point of opening the ports, I noticed that adding new open ports is not working.

Ways to reproduce:

  • Go to Open Port Check Tool - Test Port Forwarding on Your Router fill in the server (external) IP and choose port 80.
    – It will say the port is open (as configured in the firewall)
  • Remove the firewall rule of port 80 and redo the above step.
    – The response will be that the port is closed

This gives us the indication that the firewall rules are working, however if you add a new rule for (both udp and/or tcp) for i.e. port 7777, the port will remain closed. Service / system restart did not work either. (I tried multiple random ports, none seem to work)

Does anyone else have this problem? Or any way to better troubleshoot this?

Help is much appreciated!

Where is your server hosted? have you checked your provider’s port? How are your port routing in docker’s configuration?

To see is port open there need to be some service running in that port.

Thanks! As I am new to Linux/backend work I wasn’t actually aware of this. I thought opening the port and enable the port forward was enough.

For some reason I thought I wouldn’t be able to set port numbers using the CyberPanel docker GUI (few weeks ago those options were missing). Now I did use the docker to get arkserver tools installed and everything is working fine!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.