Ols version not upgraded to 1.7 even after upgrading cyberpanal

Upgraded to latest stable cyberpanal but ols is still at 1.6.21. I did downgrade it to that version a few months back due to modsec issue. But it is still at 1.6.21 even after upgrading it now??

Also did try to upgrade ols now using:
apt-get upgrade OpenLiteSpeed

But it is throwing this:
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
ols-modsecurity : Depends: openlitespeed (>= 1.7.11-1+focal) but 1.6.21-1+bionic is installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Well i did fix it using the command ‘apt --fix-broken install. But it still an issue, i guess

Can you please try upgrading it by command /usr/local/lsws/admin/misc/lsup.sh -e 1.7.14 -b and see how it goes there?

1 Like

From this article try method 2 or three and check

1 Like