OLS gone wild after update - all public files access denied despite corect vhost ownership

Hi guys, I just run a generic yum update and after that, all my websites are denied 403

I tried to run FIX Permissions from the File manager but did not fixed the situation
I checked the log and the error is “owner of file does not match owner of vhost”

I also checked the index.php ownership and seems that belongs to the user in vhost
ls -l index.php returned -rw-r–r-- 1 ukcon1234 ukcon1234 index.php

so I’m out of ideas here, OLS has gone wild somehow
any idea appreciated

I configured a new domain/website hoping that the process will show something relevant.
The new domain/website return a 404 and the permission error in logs

After that, I run the Cyberpanel upgrade script; the problem is still present.
owner of file does not match owner of vhost, path [/home/…/public_html/index.php], access denied.

go to
set redirect (again)

unfortunately, the problem is still there
owner of file does not match owner of vhost, path [/home/…/public_html/index.php], access denied

checked OLS server configuration on webadmin, checked all virtual hosts. everything is well there.
I really do not know what to check. seems like OLS do not care about vhost anymore

in that case i cant help you, sorry

i never touch OLS panel. because i have cyberpanel that should can do everything

Sorry to hear this. My only guess is that it is from the latest update to OLS. You might try asking in their forums/Slack about this.

You could also check the actual vhost files that are stored in /usr/local/lsws/conf/vhosts/<Domain>

You might also consider setting up a fresh vps instance and then comparing file details (ownership etc…) between the two. Or, just backup your web applications and redeploy them on a new instance. I recently learned how to set up a shell script for automatically configuring a new vps, so it is extremely easy to deploy a new server if I’ve broken something.

1 Like

Thanks for the ideas.
I already checked the ownership of /home files and folders. All are according to the vhosts files.
I also verified the /usr/local/lsws/vhosts/ and ownership is lsadm:nobody.
I compared folders/files ownership with another cyberpanel server and are the same.

A particularity is that this problematic server runs on Cloudlinux with CageFS, other on CentOS.

Checked LSWS basic configs and compared them with the other server and everything was the same.
Now if something messed up LSWL access to the /home dir is over my knowledge and need deep investigation. Something for sure is wrong.

Any other ideas?

How did you install cloudlinux? Here’s the official instructions, which says you must CONVERT to it rather than start from scratch.


Though, presumably it was working prior to the update, so that’s probably not it. I’d just rebuild a new vps and deploy your webapp backups there. And, if your host has the capability for backups/snapshots, start using them before running a system update.

Hi Nick, indeed CL is converted some time ago, more than 2 years and it was running smooth.
Of course, I do not keep a production server down so much time, I restored the previous day server’s snapshot immediate.
But also I take a snapshot of the corrupted variant and deployed a new vps with that to investigate the cause of the problem. More knowledge is always better :wink:

1 Like

Glad you have the backup running fine. As part of your investigation, it would be worth doing what I suggested - deploy a brand new vps instnace, install cyberpanel, ols etc… Install your web app backups and see if it all works. If so, it’s not a problem with the updated software itself

Someone just pasted this in the facebook group (which was surely an error in even approving that post).


Perhaps give it a try?