New subdomain site_url and wordpress_url are both http by default

When I create a clone of, in wordpress the site_url and wordpress_url are both set to http by default. How do I make it default to You would expect the site_url and wordpress_url to be the same as the site that was cloned.

1 Like

Welcome @d3nd0g69 Happy you are here

What is your issue? Do you want subdomain (website) to have SSL automatically when you create it?

1. To issue SSL on a subdomain website that you have already created

On CyberPanel, go SSL tab, and then Manage SSL , select domain, and click Issue SSL.

2. To issue SSL when creating a subdomain/child domain

Go to https://SERVER_URL:8090/websites/CreateNewDomain and check the SSL checkbox in additional features.

3. To issue SSL when creating a website

Go to https://SERVER_URL:8090/websites/createWebsite and check the SSL checkbox in additional features.

By default the address is set to be HTTP so if you want to https then use rewrite rules for that

I have two issues. When I go to wordpress>list wordpress> click on site and create Staging. I can clone the website but the site is created with just http and my folder permissions are not correct. So i go to file manager, select all, fix permissions and it will not work. I have to also add the s to the http everytime.

So I created a Rewrite Rule

Rewrite Rules Added by CyberPanel Rewrite Rule Generator

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

End CyberPanel Generated Rules.

However when i click on Create Staging… it will clone the site and inside of wordpress (staging clone) it is http and not https

Is is possible to force the https created in wordpress when you create staging?

Yeah, this is the same issue I am having.