My CyberPanel disappeared after 2 days

Hello! I installed my CyberPanel on AWS and it stopped working two days after installing it, it just doesn’t work anymore, even ssh.

If even ssh is not working then the server must be down from the provider.

Maybe you don’t have static and reboot changed IP in AWS.

Thanks man but static IP i’ts like a Elastic IP from AWS right?
Im sorry guys, iam not a dev or infra guy, work wit websites since 97’s but only structural planning, design and frontend. Iam from Brazil, you have no idea how difficult is to find a good hosting here, that is the reason how make switch to aws. So im need to learn a lot. :smiley: :smiley:

do you havve VPS console ?
if yes
then you can see the ip overthere… something like 123.123.123.123
try to ping ip.ip.ip.ip form your desktop

report back here …maybe i can help you

Thanks again guys for your help, alot. But you see, the problem is the installation is gone, i really need to launch my shop soon as possible, so i’m try another panel, same problem.
I miss some tutorial with a chronological configuration to make everything right.

Again, really sorry but im not a dev or infra guy, so, for exemple i had to find a list of ports in other website, by luck becouse in my “noob” mind the instalation shoul’d make this happen.

But i liked CyberPanel so much, just need he work’s right, i going reinstall it’s not a problem but i face alot of problems, such as install the principal website and he’s not be accessible from the principal domain (im beleave is becouse can’t find a cronological tutorial for instalation and configuration for a noob like me). Just need a solution, im going to reinstall everything and see whats happen.
Thanks one more time guys, sorry by my english and for be shuch a noob as dev. :smiley:

Almost forget, need to know if Elastic IP in the AWS is the same as a Estatic IP, or i don’t need use Elastic IP. I make a research and looks like the same, or not i don’t know man, so many doubts

Lets back to first question
and find out the problem 1 by 1

base on your info… you already success install OS and cyberpanel and SSH ofcourse
now the question

how you can ssh if you do not know the IP ?
if you know the ip for ssh
try to ping it …

tell me the result

This seems like an AWS issue - I’d suggest you contact their support for help.

1 Like

I already thought about it too, tried to looking for informations, and the support some times is not so easy to get. Maybe i have made some mistake at ports configurations, i found this tutorial with a list of ports How to Setup CyberPanel on AWS EC2 - CyberHosting

But ther’s an problem between 465 (SMTP default in aws) and 587. Also i dont kbnow if just need make all ports opned just for my IP, (not hhtp and https need to be opened for everybody), again make a research for ty to find the right way to do this configuration, but can’t find so much more.

So, do i need an Elatic IP or not? :smiley:

Just had a look at “elastic IP” documentation on AWS page. The say:


An Elastic IP address is a static IPv4 address designed for dynamic cloud computing. Your AWS account is assigned an Elastic IP address that is yours until you release it. By using an Elastic IP address, you can mask instance or software failures. To do this, reassign the address to another instance in your account. Alternatively, you can specify the Elastic IP address in a DNS record for your domain so that your domain points to your instance. For more information, see the documentation for your domain or Setting Up Dynamic DNS on Your Amazon Linux Instance.

So my first clue is to check if your elastic IP is assigned to the right instance inside your AWS account.

I never used AWS, but the second: Maybe there´s a firewall - so I#ll look if your elastic IP is firewalled inside your AWS account. Maybe you have to open the ports (like :8090, :7080) because they are no common standard ports.

Kai

I’m always did as you said, about open those ports 8090 and 7080. The problem (i think) was the aws send an alert when those ports are open and i realized the port 7080 was missed into the cyberpanel firewall.
So i ignored aws warning, put almos every dors openned (never 22 for ssh), put 7080 port into the cyberpanel firewall, changed htacess after import my wordpress (with all in one migration) and restart the pannel from the ssh.
For now it’s everything fine.

I’ll wait and see if everything is still working correctly, also I’m already creating an tutorial for dummies ( like me :smiley: ) for available to the community soon as possible, I hope it helps everyone.
Sorry by my english once again and thanks for your help guys.

I just had same issue. I was uploading lots of files thru FTP and cyperpanel firewall decided to ban my IP.
I could still open websites but FTP, SSH and cyberpanel ports was blocked.
I restarted my router to get new IP assigned and everything works normal now.

1 Like

If you got an aws instance, try to put the elastic ip, works fine for now.
In my case, I put elastic ip before CyberPanel install to avoid problems after instalation.
Dont forget put port 7080 in the CyberPanel firewall after the first acces.

Better to whitelist your IP in csf firewall (if you activated it)

Go to
SECURITY | FIREWALL

Search for csf-Quick Actions

Enter your IP in Quick Allow and press button
and
Enter your IP in Quick Ignore and press button

after this your IP will bypass any firewall check.

Advice: Now you can remove all admin used ports from csf port list (7080, 80,90, 21 and so on).

Your IP on allow lists is still able to reach the ports - all other ppl around the world not

But beware: This only orks if you still use the same I all the time