Migration from Apache to Litespeed help

I was just thinking if there was something important for site to work.

agree
at least tracing problem 1 by 1 to solved

Thank you for your suggestions. First I will migrate the site manually and proceed with the rest of the troubleshooting from there. I’ll update once I find the solution incase others have this same problem.

Update, here is what I’ve done so far:

  • I’ve transferred the site over manually

  • I’ve tested with the default Wordpress themes: Twenty Twenty, Twenty Twenty-Two and Storefront

  • I can confirm both DB server engines are InnoDB

The issue still exists and it hasn’t solved the problem :frowning:

Here is another example of an error I get. After seeing this error, I remove the word “public” from my functions in my class and the error is gone. Why would this error appear on the new server and not the old one? Both are PHP 7.4

I’ve installed the “Server Information” plugin and have noticed some difference. The Server on the Left is where my site is currently, and the server on the Right is where I’m migrating too. It appears the PHP versions are different, even though in CyberPanel I have 7.4 selected.

thats why i asking you to do one by one precedure…

why ?
it just ask doctor when you got headache
it can be anything…
need to trace it
without it … i doubt some one can help you for instant solution

good luck