Memcache or Redis not working

I recently created a new server on Hetzner with Ubuntu 22 and installed Cyberpanel 2.3 bulild 4. During the installation, I selected yes to both Memcache and Redis and infact both of them are showing on the installed php extensions list.

When I check phpinfo(); it doesn’t show any traces of Memcache or Redis. I tried to manually adding extensions in php.ini file but that didn’t work. In my Litespeed cache wordpress plugin, It shows disabled.

Tried installing fresh Cyberpanel few times on other servers too but those are also having same issue.

I have another server that I had set up few months back, which has Ubuntu 20 and Cyberpanel 2.3 but Build is 2. It has both the extensions installed and showing enabled.
I suspect it could be an issue on cyberpanel latest build or something else is updated and causing not to work

1 Like

Ok I figured out the issue. In Apache manager I enabled Apache as reversed proxy. After enabling pure Litespeed server, Memcache and Redis got working

usmannasir It will be great If anyone has solution for Memcache or Redis when Apache is set as reversed proxy while creating a website.

I had the same problem, and found the solution. I’m a beginner, but the problem was solved by switching to an old PHP version 7.4 and back again to the latest version 8.1

I got redis working just by installing apache redis php extension.

Can be found from cyberpanel → PHP → Install extensions → MANAGE APACHE EXTENSIONS