Mautic installation fails due to curl extension

I created the website and im trying to install mautic but the installation fails with this error

Installation failed. Error message: [“Mautic Install”,“==============”,“”,“Parsing options and arguments…”,“0 - Checking installation requirements…”,“Missing requirements:”," - [0] Install and enable the curl extension.“,“Install canceled”,” [404]"]
I have curl installed but I reinstalled it but I keep getting same message.

this is what i get in the browser.

Mautic does not support PHP version 8.1.14 at this time. To use Mautic, you will need to downgrade to an earlier version.

I installed sudo apt-get install php-curl

but still no go. I tried all other version of PHP like 7.4,3,2,1 but no go.

I have cyberpanel installed on ubuntu 22.04

Ramdhan Mubarak @sheikh73

What error are you getting so far using php7.4 ?

Same message. I tried again with 7.4 which is recommended I get this message

Installation failed. Error message: ["PHP Warning: PHP Startup: 
Unable to load dynamic library 'curl' (tried: /usr/local/lsws/lsphp74/lib/php/20190902/curl (/usr/local/lsws/lsphp74/lib/php/20190902/curl: cannot open shared object file: No such file or directory), /usr/local/lsws/lsphp74/lib/php/20190902/ (/usr/local/lsws/lsphp74/lib/php/20190902/ cannot open shared object file: 
No such file or directory)) in Unknown on line 0","Mautic Install","==============","","Parsing options and arguments...","0 - Checking installation requirements...","Missing requirements:"," - [0] Install and enable the <strong>curl</strong> extension.","Install canceled"," [404]"]

I deleted the website and recreated every attempt of nautic. This time with php7.3 I don’t see mautic app available to install. What happened. I create website again to check

Mautic only works with PHP 7.4 and 8.0.

Also check what your memory limit and other php configuration is before installing Mautic.

I installed Centos7 and then installed mautic and it worked. I think ubuntu is not an os for it.

This issue is very clear you do have dynamic library curl for php7.4

and how can we fix it?

I just installed centos7 and installed cyberpanel and then Mautic. All went well

In Ubuntu when I was trying to install mautic I deleted and created website with ssl so many times. Now when I’m trying to issue a ssl certificate. I get error message.

This means Mautic Installtion went well. The only issue is Mautic unreleated. What error are you getting ?

Mautic is not OS specific. Kindly read through the documentation