Mail SSL certificate error

My Cyberpanel host is I pointed this host at my Cloudflare DNS server (Cloudflare is my DNS server). I have issued SSL for the host, mail server, and web for

Now I am adding the domain name to my panel. The system automatically created the subdomain I have created a record called mail in Cloudflare and declared MX for with the value I have enabled SSL for and for the web. When I connect Outlook via imap, I receive an SSL certificate error. It is showing that the certificate is being issued by

I am new to CyberPanel. I was using HestiaCP, and this problem was not there. How do I solve this issue? I will host around 30 domains on this CyberPanel host.

Thanks in advance.


Is the mailserver domain. The one and only.

Did you follow the instructions here Achieve 10/10 Email score with CyberPanel!

You do not need to do anything extra beyond this. Just add your customer domains and setup mailserver as the primary mailserver domain or their own e.g. will have or hey can use (I prefer this - no mail certificate issues) however both work perfectly with CyberPanel.

Solution to your problem

  1. Issue mailserver ssl to and no other domain whatsoever.

  2. Ask your customer to use or

  3. Your cf records are ok dont touch them.

  4. To onboard new customers - create website make sure to tick mail domain checkbox then create email adresses and that is it.

What if I individually assign a mail server certificate for, ?

We do not do that here

I followed your guide and now I am getting SSL error while adding a domain named and are seperate domain.

I think, I have to change cyberpanel hostname to a separate domain. All other domain I am adding is working perfectly but anything related is problematic.

Sorry i noticed my error and have update my post

Thanks a lot. It worked. Have a great day.

anyway to put the mail domian as webmail page? for example will open the webbased email system?

Should I put a reverse entry for or ?

Webmail page is

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.