Local-incremental-backups-in-cyberpanel 100% CPU

two days with backup
two days without backup

one day without backup

when activated the daily backup at some 100%CPU time.
only resolves server reset.
but the problem remains…it seems to loop…

is up to date.

Please share your server configuration
Hosting provider name
Also, do cyberpanel upgrade using ssh upgrade command of cyberpanel.

vultr
image

I will arrange and do new tests, as soon as I have the result posted here. thanks

You have very low configuration server. It is obvious that backup feature will spike the CPU usage as its a resource heavy operation.

forgive.
I’ll try to explain .
I know it increases but it stays for hours.
you need to restart the server.
if you don’t restart the CPU remains at 100%
thanks

it looks like it’s in an infinite loop

I found this post coherent.
I did not understand .
told to remove the beckup so I did.
but if reschedule happens again 100%CPU.

I have seen this on a few servers, top reveals a couple of Python processes together using 100% cpu, they do not go away until you make them go away. “top -c” will show something like:

/usr/local/CyberCP/bin/python /usr/local/CyberCP/plogical/IncScheduler.py Daily

In Cyberpanel check your scheduled backups there is one or more that is bad and needs to be removed. Once removed kill both python processes and they will stay killed and should not return as long as you have the bad backup schedule removed.

I don’t know if you can post the post url.
The information is not mine I found the post that solves it, but I didn’t have the backup
thanks

Have you tried to re-run the upgrade command of cyberpanel using SSH?
Because recently there was backup related fixes done in github branch.

was already up to date.
but run the ssh update command today.
I’m going to turn backup on again. test to see the behavior.
post the result here soon

thanks

1 Like


performs the backup but is in a loop.
it looks like a break is missing.
I disabled the daily backup.
let’s wait

I redid some tests.

tried to do manual incremental backup gave folder permission error.

I granted the folder permission and tried to do the incremental backup.

everything went fine until I started doing the database… can’t back up the database, it’s looping…

I rerun the test without the database and completed the incremental backup…but without the database

thanks

Check Cyberpanel main logfile;

/home/cyberpanel/error-logs.txt

If error messages ;
“mysqldump: Got error: 1045: “Access denied for user ‘root’@‘localhost’ (using password: YES)” when trying to connect”

The changed MySql root passwords needs to be mentioned/edited in these files:

/root/.my.cnf

And Check;
/home/cyberpanel/.my.cnf
/etc/cyberpanel/mysqlPassword
/usr/local/CyberCP/CyberCP/settings.py

systemctl restart lscpd

Good luck…

The issue happened only when you have changed the root MySQL password you provided the details