As I already mentioned in post: Cannot issue SSL for Hostname. New to Cyberpanel - already having problems. — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

I’m having problems with SSL, I’m starting this thread as fresh just in case it’s a larger issue and not just SSL problems.

I tried updating CyberPanel using the command in the guide, running the update killed my panel… 503… tried to restart Gunicorn, works… then dies straight after.

I’m starting to get very frustrated at this panel and would appreciate some info and assistance.


To let you know my steps so far:

  • Rebuilt server as CentOS 7.x from scratch
  • Fresh install of CyberPanel using the instructions outlined here:
    sh <(curl || wget -O -
  • Server installation completed, output of the entire log from the install is attached to this post.

There were a bunch of errors and warnings, which frustrate me as this is a fresh install of the OS and directly installed using the script… so if someone from the dev team wants to look over the export, they should… go and fix some of those errors if you can.

The one that got me was “WARNING: can’t open config file: /usr/local/ssl/openssl.cnf” - This doesn’t look great.

Lots of notifications about PIP being out of date… but this is the one which with your installer… so I guess that needs looking at too.


Username: admin
Password: 1234567

  • Login using the credentials provided
  • Dismissed the “Your connection is not private” message and continued
  • Immediately changed the admin password
  • Selected “Create Website”
  • Package > Default
  • Owner > Admin
  • Domain: (which resolves to this IP using GoDaddy NS’s)
  • Email address entered
  • Selected PHP 5.6 - but that won’t matter as it’s going to be the host address
  • STARTED to follow these instructions: 2 - Creating Website - CyberPanel
  • Checked SSL, last time I did not check that box, even though it says that it’s optional (for the CyberPanel to be on SSL)
  • Pressed Create Website and “Website with domain is Successfully Created”


  • When visiting “” I get the HTTP version
  • Rebooted the server just in case it needed to propagate the changes
  • Still only loads the HTTP version, HTTP gives “NET::ERR_CERT_AUTHORITY_INVALID” if trying to access via HTTPS
  • Logged into the panel again using
  • Ignored the SSL warning and proceeded
  • Now continued following the instructions: 2 - CyberPanel on SSL - CyberPanel
  • Main > SSL > Hostname SSL
  • Select Website >
  • Issue SSL: “Cannot issue SSL. Error message: 0,[Errno 2] No such file or directory: ‘/etc/letsencrypt/live/’”

Of course, now everything is basically screwed because the panel doesn’t connect property to the subdomain under SSL - which is not acceptable.

Figured I’d try and re-issue the certificate as outlined in the CyberPanel on SSL and this is the message I get now:

Cannot issue SSL. Error message: Command ‘[‘sudo’, ‘python’, ‘/usr/local/CyberCP/plogical/’, ‘issueSSL’, ‘–virtualHostName’, ‘’, ‘–administratorEmail’, ‘’, ‘–path’, ‘/home/’]’ returned non-zero exit status 1

So yeah. DEAD. And It’s driving me crazy. Any help would be massively appreciated.

I didn’t miss anything out here… so any suggestions?

The problem is it is not a fresh install, you already have apache installed with your VPS. Some VPS providers have apache installed with their VPS.

You need minimal centos installation, or before starting installation make sure you don’t have any LAMP/LEMP stack already installed.

About the warnings, you can just ignore, but remove any web server stack before installing CyberPanel.

I will update installer script and add apache check beforehand

added apache check in installer script , submitted to GitHub …


To install any panel you need to make sure that you should install it on fresh OS. No, LEMP / LAMP / Postfix / Dovecot / etc.

If you have LAMP / LEMP, etc, and you don’t really ‘clear’ it, you will encouter many problem.

So, it is not caused by CyberPanel, but it is caused by your unclean VPS.

What you need to do is to reinstall your operating system, then install CyberPanel again, and you will see that CyberPane is amazing panel :slight_smile:

Nice one! Great response, I trust that it’s a great panel, I just need to make sure it’s as easy to work with as possible :slight_smile:

I’ve received a response from the VPS company I’m working with and it seems they don’t have minimal builds, but I directed them to our thread, and they responded:

“Our servers do come with apache preinstalled, some with mysql as well, so after you reinstall your server, before installing your software you have to remove it by running something like: yum remove httpd”

You think that’s sufficient? I’ll try and rebuild now!

BOOM! That’s all it was. Removing httpd was the solution! @qtwrk DEFINITELY worth adding this as a prompt or even having the script remove any other currently installed (and possibly conflicting) components.

Alternatively, please update your documentation to include this information!

Looking forwards to using this pane! - Undoubtably I’ll be back with more questions or frustrations ;)! :stuck_out_tongue: Until then, thanks @gabrielwaskito, @qtwrk and @usmannasir