Installer breaks YUM feature


when i run following command “sh <(curl || wget -O -” it some how breaks the yum repos completely on centos 7.5, because when i ran yum before this it could connect just fine, but once i ran the command it now just keeps trowing error like “Unable to connect to host” and it won’t go anywhere than this. It also said yum repo file contains broken repos.

so something within the installer is adding a broken repo so the yum command cannot run anymore.

also if i re-run the installer command i also get this aswell now "curl: (6) Could not resolve host:; Unknown error
–2018-08-02 23:16:53--
Resolving (… failed: Name or service not known.
wget: unable to resolve host address ‘

please fix this.


What to do you have in /etc/resolv.conf

And what is the output of ping

strange, either the resolv.conf got flushed by installer or something since before i ran the cmd it worked fine with yum reciving connection from outside. But once i ran installer command it broke and resolv.conf was only having “nameserver” instead of actually one, so it sems installer resets it or something. So now i assigned a nameserver to it and it works again.

CyberPanel install script (initial bash and python) does not modify /etc/resolv.conf in any way.

I installed CyberPanel couple of times today without any issue, something wrong with DNS resolution on your virtual machine. But it’s great that you have solved it now.

well i disagree on that, since i ran script twice. ran it once, it broke the internet connection, so i reinstalled os again from scratch and ran installer again. But guess what it broke the connection for 2nd time. so something it’s doing on installer, since this is only installer doing it. if i try any other panels out there it’s fine, so yeah. that’s why i still think theres something in installer coding that flushes something. But main thing is i got it working now, but i still suggests you to check installer script, it’s some where it imports a database/library or w.e it’s called to the yum part where it breaks.

Can you fresh install your os and send logins via ticket: Home - CyberPanel

I would like to try and see of there is something wrong.