Installed GhostCMS on Docker but got 404 not found

I install wordpress and then try to replace my current website with a ghost platform, but my website shows 404 error,
ubuntu 18

My system and cyberversion 
Current Version:




Current Commit:


Latest Version:


Latest Build:


Latest Commit:


You can check the FileManger

Check the eroor message

My ghost show everthing running noraml

Welcome @Jason866 Happy you are here

Look through this and let us know what you have tried so far or which tutorial you followed above and beyond the Ghost docs

1 Like

seems nothing works !any option to use my ghost website !

Have you tried to deploy using pm2 process manager it will tell you what is going on ?

Also make sure you are not using any version below v5.22.7 there is security vulnerability

No, I delete wordpress file from the file manager then try to install the ghost using the container option from the dashboard but it’s seems not working at all! any idea How to fix my issue or use another option?

check my website :
How To Fix Error 404 Page Not Found In WordPress | 404 Not Found In Bangla tutorial 2022 - YouTube

How to solve the issue

Clearly you did not follow any advice we gave you.

Why are you using wordpress manager ?

Are you using docker ?

For example How to install & setup Ghost on Ubuntu 20.04 or 22.04 it states

Before getting started you should set up a working DNS A-Record from you domain, pointing to the server’s IP address. This must be done in advance so that SSL can be configured during setup.

This means you just create a website for your domain and that is it.

Then Install Ghost-CLI read the docs on how to do this

Then skip the install Ghost process as Ghost comes with NGINX and SSL setups of its own this I can see you knew how to get around this. Just to highlight it for the community its usually running:

$ ghost setup --no-setup-nginx --no-setup-systemd --no-setup-ssl --no-start

Reboot your server or just run systemctl restart lsws

Now for good measure install PM2 read the tutorials I highlighted above to know what is wrong with your installation if any. With ghost cli you will hardly ever need pm2 because they all monitor the app and can restart, start and stop it.

yes, I install docker then fellow some toturial online How to install ghost cms using ceyberpanel then I found some issue related about lite speed firewall. Any steps or commands to undertsand why the error stuck 404

Did you follow any tutorial here? If any highlight it here

Did you pull this image Docker or what image are you using to create your container ?

If you are running a web application in your Docker Container you may want to reverse proxy traffic from main webserver (OpenLiteSpeed or LiteSpeed Web server Enterprise) to docker container.

Did you see this Reverse Proxy Traffic to Docker Container on CyberPanel ?

Tried to explore an example like this How to install NextCloud on CyberPanel with Docker

Post a screenshot of this issue

Check some error

And my website show 404 page. I fellow some instruction deleted my website then tried to create new one(seems nothing works)

Copy paste here the logs you see down there. All of them

[2023-05-11 09:21:52] e[36mINFOe[39m Ghost is running in production...
[2023-05-11 09:21:52] e[36mINFOe[39m Your site is now available on
[2023-05-11 09:21:52] e[36mINFOe[39m Ctrl+C to shut down
[2023-05-11 09:21:52] e[36mINFOe[39m Ghost server started in 9.914s
[2023-05-11 09:21:54] e[31mERRORe[39m connect ECONNREFUSED
e[31mconnect ECONNREFUSED[39m

e[33m"Unknown database error"e[39m

e[1me[37mError ID:e[39me[22m

e[1me[37mError Code: e[39me[22m


e[90mError: connect ECONNREFUSED
    at /var/lib/ghost/versions/5.47.0/node_modules/knex-migrator/lib/database.js:57:19
    at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1278:16)e[39m
[2023-05-11 09:21:54] e[35mWARNe[39m Ghost is shutting down
[2023-05-11 09:21:54] e[35mWARNe[39m Ghost has shut down
[2023-05-11 09:21:54] e[35mWARNe[39m Your site is now offline
[2023-05-11 09:21:54] e[35mWARNe[39m Ghost was running for a few seconds
type or paste code here

What are your docker mysql settings post a picture here seems you didnot use another port for this because your whole cyberpanel installation is running mariadb on that port

I use

Container ID: 00a3e05851383d0784453cc0eb3431f5e6083ad86daae8d1695baa026738f44c
Image: ghost:latest
2368/tcp to 2368

Did you try to restart the container ? Would you use sqlite to see if it works ?

1 Like

Yes I try check my domain name works and use index.html, If I remove the file the whole website show 404 error. Can I try to modify the port to 3306 ?

Yes you can change cyberpanel’s mariadb port to any open port on your server Some Dont's After Installing CyberPanel! (dont mind the title)

How do I do that? any option, how to point my domain into my ghost folder and not the index?html

Reverse proxy already taking care of that if you are using docker. What I meant is you could try change mariadb port of cyberpanel and see if the docker container will work now

You are always welcome to try this method My website show 404 not found and the server is running normal - #6 by josephgodwinke which I highly recommend

How to change the port ???

If you have changed cyberpanel mysql port from 3306 or its open, yes try that.