Installation Failing on Centos 7

Can’t install on fresh Centos 7 install.

[04.29.2022_13-44-39] Fixing OpenLiteSpeed configurations!,50
[04.29.2022_13-44-45] OpenLiteSpeed Configurations fixed!,50
[04.29.2022_13-44-45] Running: /usr/local/lsws/bin/lswsctrl restart,50
[04.29.2022_13-44-49] Successfully ran: /usr/local/lsws/bin/lswsctrl restart.,50
[04.29.2022_13-44-50] Installing MySQL,60
[04.29.2022_13-44-51] Running: yum --enablerepo=mariadb -y install MariaDB-server MariaDB-client,60
[04.29.2022_13-46-05] Successfully ran: yum --enablerepo=mariadb -y install MariaDB-server MariaDB-client.,60
[04.29.2022_13-46-16] Running: yum install -y pure-ftpd,60
[04.29.2022_13-46-22] Successfully ran: yum install -y pure-ftpd.,60
[04.29.2022_13-46-24] Running: systemctl enable pure-ftpd,60
[04.29.2022_13-46-25] Successfully ran: systemctl enable pure-ftpd.,60
[04.29.2022_13-46-25] Running: groupadd -g 2001 ftpgroup,60
[04.29.2022_13-46-26] Successfully ran: groupadd -g 2001 ftpgroup.,60
[04.29.2022_13-46-26] Running: useradd -u 2001 -s /bin/false -d /bin/null -c "pureftpd user" -g ftpgroup ftpuser,60
[04.29.2022_13-46-28] Successfully ran: useradd -u 2001 -s /bin/false -d /bin/null -c "pureftpd user" -g ftpgroup ftpuser.,60
[04.29.2022_13-46-29] Configuring PureFTPD..,60
[04.29.2022_13-46-29] Running: openssl req -newkey rsa:1024 -new -nodes -x509 -days 3650 -subj "/C=US/ST=Denial/L=Springfield/O=Dis/CN=www.example.com" -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem,60
[04.29.2022_13-46-30] Successfully ran: openssl req -newkey rsa:1024 -new -nodes -x509 -days 3650 -subj "/C=US/ST=Denial/L=Springfield/O=Dis/CN=www.example.com" -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem.,60
[04.29.2022_13-46-31] Running: sed -i 's|localhost||g' /etc/pure-ftpd/pureftpd-mysql.conf,60
[04.29.2022_13-46-31] Successfully ran: sed -i 's|localhost||g' /etc/pure-ftpd/pureftpd-mysql.conf.,60
[04.29.2022_13-46-32] Running: sed -i 's|3306||g' /etc/pure-ftpd/pureftpd-mysql.conf,60
[04.29.2022_13-46-38] Successfully ran: sed -i 's|3306||g' /etc/pure-ftpd/pureftpd-mysql.conf.,60
[04.29.2022_13-46-38] Running: sed -i 's|MYSQLSocket /var/lib/mysql/mysql.sock||g' /etc/pure-ftpd/pureftpd-mysql.conf,60
[04.29.2022_13-46-39] Successfully ran: sed -i 's|MYSQLSocket /var/lib/mysql/mysql.sock||g' /etc/pure-ftpd/pureftpd-mysql.conf.,60
[04.29.2022_13-46-39] PureFTPD configured!,60
[04.29.2022_13-46-40] Running: systemctl start pure-ftpd,60
[04.29.2022_13-46-41] [ERROR] We are not able to run systemctl start pure-ftpd return code: 1.  Fatal error, see /var/log/installLogs.txt for full details.
[04.29.2022_13-46-41] [ERROR] We are not able to run systemctl start pure-ftpd return code: 1.  Fatal error, see /var/log/installLogs.txt for full details.

Oops, something went wrong... [404]

Starting installation..,1

Initialization completed..,2

command failed, exiting. For more information read /var/log/installLogs.txt [404]

command failed, exiting. For more information read /var/log/installLogs.txt [404]

Setting up repositories...,1

Installing necessary components..,3

Installing required virtual environment,3

Installing requirments..,3

Getting CyberPanel code..,4

Necessary components installed..,5

Setting up system tweak...,20

Starting main installation..,30
[04.29.2022_13-51-45] Starting CyberPanel installation..,10
[04.29.2022_13-51-46] Running: yum install sudo -y,10
[04.29.2022_13-51-49] Successfully ran: yum install sudo -y.,10
[04.29.2022_13-51-50] Running: useradd -s /bin/false cyberpanel,10
[04.29.2022_13-51-50] [ERROR] We are not able to run useradd -s /bin/false cyberpanel return code: 9.  Fatal error, see /var/log/installLogs.txt for full details.
[04.29.2022_13-51-51] [ERROR] We are not able to run useradd -s /bin/false cyberpanel return code: 9.  Fatal error, see /var/log/installLogs.txt for full details.
[04.29.2022_13-51-51] [ERROR] setup_account_cyberpanel. 71, see /var/log/installLogs.txt for full details.
[04.29.2022_13-51-52] Running: rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1.el7.noarch.rpm, see /var/log/installLogs.txt for full details.
[04.29.2022_13-51-53] [ERROR] We are not able to run rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1.el7.noarch.rpm return code: 1.  Fatal error, see /var/log/installLogs.txt for full details.
[04.29.2022_13-51-54] [ERROR] We are not able to run rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1.el7.noarch.rpm return code: 1.  Fatal error, see /var/log/installLogs.txt for full details.
[root@localhost ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs         36G     0   36G   0% /dev
tmpfs            36G  136K   36G   1% /dev/shm
tmpfs            36G   17M   36G   1% /run
tmpfs            36G     0   36G   0% /sys/fs/cgroup
/dev/sda3       926G  7.7G  918G   1% /
/dev/sda1      1014M  170M  845M  17% /boot
tmpfs           7.1G     0  7.1G   0% /run/user/0

Please run yum update and then try to install cyberpanel

Same issue here but with cloudlinux 8.5 (I runned the yum update :smiley: )

I try to reinstall the whole system like 2-3 but always have problem… :confused: Fresh install activated cloudlinux.

Starting main installation..,30
[05.01.2022_12-18-31] Starting CyberPanel installation..,10
[05.01.2022_12-18-31] Running: yum install sudo -y,10
[05.01.2022_12-18-34] Successfully ran: yum install sudo -y.,10
[05.01.2022_12-18-34] Running: useradd -s /bin/false cyberpanel,10
[05.01.2022_12-18-34] [ERROR] We are not able to run useradd -s /bin/false cyberpanel return code: 9.  Fatal error, see
$[05.01.2022_12-18-34] [ERROR] We are not able to run useradd -s /bin/false cyberpanel return code: 9.  Fatal error, see
$[05.01.2022_12-18-35] [ERROR] setup_account_cyberpanel. 71, see /var/log/installLogs.txt for full details.
[05.01.2022_12-18-35] Running: rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1.el7.noarch.rpm, see /
$[05.01.2022_12-18-36] [ERROR] We are not able to run rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1
$[05.01.2022_12-18-36] [ERROR] We are not able to run rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.2-1$
Oops, something went wrong... [404]

@shoaibkk
Any tipp?