Installation always seems to end prematurely

I’ve attempted to install CyberPanel 3 times with a VM, and then reluctantly on baremetal thats otherwise in-use, and they all seem to end prematurely. All starting from a fresh Ubuntu 20.04 install.

After about 10min the screen goes black and i have a blinking white underscore, and it stays like that till i reboot it. Having watched other videos of the installation, it looks like i get about half way through.

This is the last frame before it goes black:

I decided i’d make a 5th attempt, record it and upload to Youtube (unlisted) so you can see for yourself.

Spent 9hrs on nothing more than multiple attempts at getting this to work and faffing about with things surrounding it, but it would have been considerably more painful if i hadnt tried with cloned VMs before installing.

Is there something i did wrong or can fix to make this work?

1 Like

let me summon the master :slight_smile:

came here by your self and return by your self

Which hosting isthis? It seems after installing firewalld and thereafter restart command for systemd logind the installer is not able to connect back due to restricted session.

Is your vps having dynamic IP?
Is your vps having firewall services in place? You will need to open the relevant ports beforehand if so.

Its my own hardware.
VWware 16 on Win10 (given 4 cores, 4GB ram & 40GB storage).
Then when that kept failing, an old HP Microserver (10yo Celeron, 2gb & 64gb)

All using a fresh ubuntu 20.04 install, so whatever their default would be i guess. I checked i meet all the requirements for the installation (OS, python 3, 1GB & 10GB) and i cant imagine being physically at the hardware would be a problem, but i guess the environment might be correct for an OS not but a hosting platform, and the VM i would have thought would work if a VPS did.

Im considering going down the VPS route, but really i wanted to spend some time using CyberPanel and know what im doing with it without spending money to do so only to find out its too much for me to wrap my head around.

Any advice? an OS that you know fill work in such a situation?

You can use Upcloud Sign up - Cloud servers with best price vs performance - UpCloud
And use this coupon code: WE39BV
You will get 25$ credits in your account after using the above coupon code.

You can start using the 5$ server and test Cyberpanel in it as you mentioned that you need to spend some time using Cyberpanel before spending money on VPS hosting.

Actually there maybe many reasons for your setup to not work efficiently. But I believe its something more of a Network or firewall configuration issue. Something is blocking access to the sessions created.

Its better to use VPS than local server.

I figured it out yesterday, it was pretty obvious from the video tbh. Im using terminal, having done bits of command line before and this looked no different.
When doing it remotely with SSH, the point where it was breaking is when the OS logs out the user, and is presumably killing the script in the process.

The problem i have now is that after following the Auto import cPanel sites to CyberPanel instructions i get the following:

/usr/local/CyberCP/bin/python /usr/local/CyberCP/plogical/ --path /home/paul/Downloads
Backup logs to be generated in /home/cyberpanel/7399
[Errno 2] No such file or directory: '/home/backup/'

and the log says very little:

Extracting main cPanel archive file: /home/paul/Downloads/
/home/paul/Downloads/ successfully extracted.
Creating main account from archive file: /home/paul/Downloads/
Failed to create main website from backup file /home/paul/Downloads/, error message: list index out of range.

This account doesnt exist already, and doesnt exist after running. But it might be relevant that theres a site already, but not a .com

make sure already root
and try to change the folder to

before start the progress

and try to remove existing account first

I might be misunderstanding some of that, so bare that in mind…

  • ‘already root’ - im logged in as root when attempting the cPanel importer script.

  • ‘/usr/local/src’ - place the cpmove file into that folder?

  • ‘remove existing account’ - there wasnt one for this site, a .com, only a .xyz for testing purposes. But ive now removed it either way, its unimportant.

It says ‘no such file on directory’ (see previous msg), and in /home/backup there is a folder named what cPanel used when creating the backup in backup wizard.


Is the cPanel backup wizard the appropriate place to do this? I sure its what ive used when relocating to new hosts, and then renamed it to cpmove-[domainname].tar.gz

So the problem is cPanel isnt creating the backup file that the CyberPanel script is looking for. I dont know whether thats down to how my host has cPanel configured or not but my older backups are exactly the same.

My cPanel generates the backup as: backup-1.27.2022_08-39-27_domain.tar.gz
It extracts the folder, but instead of finding /cpmove-domain.dom its getting the above, and so it cant find /userdata/cache.json.

So ive unpacked the contents, renamed the folder for cyberpanel, and then zipped it up again. That seems to be allowing the import script to run, but its showing multiple errors. Verify error:Invalid response from

I have 2 of those for the domain and its subdomain.

Thats what the result from my primary domain, not sure whether or not those errors are critical, but the only thing of relevance to me on that domain is my email, and when i go into email and select the site, it says “No emails exist for this domain.”

When i look at the file manager, theres nothing there, either. 2 folders;
both with 2 files in each. less than 100kb between em.


and that folder depend on your distro
in my case i use ubuntu 20 LTS

dont create website(account that have similar name with your backup --this is just my own guess)

put this file to /usr/local/src or other folder depend on your distro

ref: Auto import cPanel sites to CyberPanel - CyberPanel

Cheers, i’ll give that a go, but i think im already past that and having just as many issues there. I’ll try this though in case its functionally different.

Im on AlmaLinux now if thats at all relevant, i was trying other OSs and then realised the SSH was significant. So just stuck with it cos i dont honestly care what OS i use as long as it works.

then this is the time to summon @die2mrw007

sry brother, i cant help you more… you need technical help… i hope @die2mrw007 will be here soon…

btw, fyi, oot
im in plan to install alma for my cyberpanel…

i think i must caarefull and check all before i use it for production

1 Like

Yeah, exactly the same, just inconsistently broken sites.
My main site where i only care about the email address, has no email, no files, no databases. A site i host for a friend has about 10% of the site files, both email address (corrupted), and all 4 databases (looks okay).

I think im gonna have to wave the white flag, im not in the right frame of mind for all this at the moment. I’ll come back and take a better look when theres no deadline looming. I just kinda hoped that there was a low effort install and click a few buttons type solution, as my needs arent anything special, but im clearly out of my depth with hosting & linux.
I wanted to try and go self-hosted and get away from shared/reseller accounts at some point this year, and then over xmas my host lost 3wks of data on their ‘US server’ and needed me to point this out to them after 3 days of downtime. Im still leaving, just gonna have to stick with WHM/cPanel a while longer.

@MyIDKaTePe - Thanks for trying to help, its much appreciated.

1 Like

Sorry, I am currently not reading all the above posts as I am short on time. To cut short, you were having issues with installing cyberpanel as it was not getting completed because the script was not able to connect back to the OS due to some network of firewall issues it seemed.

Were you able to install it correctly without errors?

Briefly looking at your other posts it seems you are facing cPanel migration issue. Are you using the migration script after installing cyberpanel successfully or are you trying to use the migration script before installing cyberpanel by any chance?

Please let me know what are your issues currently as of now in your next post so that I get a clarity on the issue and provide you the best possible solution.

1 Like

Yes, i believe i completed the installation, but i honestly cant tell if its working as you intend/believe or it simply completed the installation but wasnt 100% successful, and so im getting a problematic experience.

For the cPanel import from backup, it was a complete mess. Whether it was importing absolutely nothing, just creating the domain and nothing else, to 90% of the site files being missing, databases being present, but mailboxes being corrupted. 2 backups, same results each time i tried.

I ended up just moving to a new cPanel host because my deadline was up and i need to go somewhere, and they restored the exact same backups without any issues, so i dont believe it was the backups.
All that said, at some point i’d still like to get something up and running, but ive had too much going on lately and my health is taking a beating trying to figure (multiple) things out and so ive bought myself a years hosting to eventually come back and take my time figuring stuff out.

As in my previous post I have provided you with an option to get free vps hosting from upcloud for few months. You can try that to experiment with cyberpanel and get familiar with it. If any issues, you can post in this community forum and we all will help you.

1 Like