Install SSL on cyberpanel dashboard

i know how to instll the ssl certificate on a website but i don’t know how to install the ssl certificate on cyberpanel dashboard . It is showing without green lock

Have you set IN NS of your domain to your cyberpanel server ?
or IN A maindomain, www.maindomain cpanel.maindomain mail.maindomain ftp.maindomain to your server’s ip ?

Check out this link 2 - CyberPanel on SSL - CyberPanel

You cannot issue Letsencrypt SSL to a naked IP address. Certificate for public IP without domain name - Issuance Tech - Let's Encrypt Community Support

you need to set hostname to have domain linked to cyberpanel IP

okay sir so I’m currently using contabo vps server and i change the hostname in contabo by panel.mydomain.com and did the dns mapping in cloudflare but I cannot getting the access of cyberpanel dashboard by panel.mydomain.com:8090

please help me or send me any instruction link.
NOTE: I’m using cloudflare for dns management so is this the problem cause ?

well sorry for my bad english

correct me if im wrong
you want panel.mymain.com to Cyberpanel (cp) server as 8090 directly ?
like domain.com/otherpanel then the addressbar change to domain.com:2083

right ? if correct… i will continue
(sorry if you already did some step)

  1. domain panel IN NS ns1.cloudflare ns2.cloudflare
  2. at cloudflare dns panel
    panel.domain.com IN A 321.321.321.321
    panel.domain.com IN A 321.321.321.321
    (change to your server ip)
    note: mx and dkim spf is other story
  3. setup server hostname etc etc
  4. install cyberpanel
  5. open cyberpanel using 321.321.321:8090 (at this point, this is how i did. maybe there is another solution)
    4.1 add website panel.domain.com
    4.2 open DNS editor
    4.3 check the panel.domain.com inside the zone or not
    4.4 try open panel.domain.com (http)
    4.5 add ssl domain, add ssl main, add hostname
    4.6 check https://panel.domain.com …working or not ( better to not behind proxy @CF)
    4.7 open other tab
  6. https://panel.domain.com:8090
  7. if working…
    6.1 edit index.html add header forward to https://panel.domain.com:8090

done

it can be explained in short…

just add header request forwarder :stuck_out_tongue:

but i dont know u understand the flowchart or not,

1 Like

Can you send me the hostname domain you used? Along with the DNS settings you changed for this?