Index.html 404 Error in OpenLiteSpeed fresh install


I installed Alma Linux on VPS, then I update it, then I installed CyberPanel with OpenLiteSpeed and now I’ve created a fresh site in public_html I only have the basic index.html file.

When I write the server’s IP in the browser, I get the 404 error from OpenLiteSpeed. I even tried to open it as a IP/index.html but still I got the 404 error.

I checked the permisions for both the public html (drwxr-x—) and index.html (-rw-rw-r–) and they are just like in the shared hosting with cPanel that I want migrate to the VPS.

As I said, this is a fresh install and didn’t change anything and simply I don’t understand why I can’t access the index.html file.

Please help me!

I found out what was the problem: I had to map the vHost Config of the new site to domain in Listener.

So I used the OpenLiteSpeed interface in Chrome, then I went to “Listeners” I clicked on “SSL” and in “Virtual Host Mappings” and added a new virtual host called “Example” and in the domain field I put my server’s IP address.

This will load the OpenLiteSpeed wellcome message. If you want to open your index.html when you put your server’s IP in browser, you need to go also to OpenLiteSpeed / Virtual Hosts click on “Example” go to the “General” tab and in the “Document Root” add the path to your public_html For example: /home/ Don’t forget to replace “” with your domain name.

I said to write this here, because a lot of people had the problem with 404 Error of OpenLiteSpeed after installing Cyberpanel and adding a website and entering server’s IP in browser, and nobody came anywhere with a solution.

It will help you this with anything? No. I just learned something new, but it won’t really help me. I just wasted time, instead of just configuring the DNS and changing the DNS at my registrar and after propagation anything should have worked just fine without me mapping anything.

But… if I wanted to know when I enter my server’s IP in browser, why the OpenLiteSpeed will return a 404 Error… what can you say? Haha

I hope it helps you,


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.