Incremental backup to SFTP

Provider: My own server

Virtualization Type: Proxmox

System: Ubuntu 18.04

OLS or Enterprise?

Installing from official server or mirror server?


When I run scheduled incremental backup to SFTP I get the following errors:
Fatal: create repository at sftp:* failed: config file already exists
and ‘NoneType’ object has no attribute ‘find’. [IncJobs.initiateRepo.47][5009]

I was told it was because my previous backup may have failed. So I deleted the folder of the website on the SFTP server. And ran the scheduled backup script with: python /usr/local/CyberCP/IncBackups/ Daily

It did all the things correct this time it seemed and said completed. Then when I run it again I get the same error

Oh it also says: /usr/local/CyberCP/lib/python3.6/site-packages/django/db/models/fields/ RuntimeWarning: DateTimeField received a naive datetime (2020-04-01 13:46:40.359116) while time zone support is active.

Both when I run it when there is no folder and it seems to work, and also when it fails.

Fixed by upgrading to cyberpanel to 2.0.0

I have same problem. on centos 7, with cyberpanel 2.0 (1). tryng to restore from Amazon aws.
" Reconstructing with meta…
‘IncJobs’ object has no attribute ‘restoreTarget’ [88][5009] "

     This is a real problem