I cant send or receive emails v1.9.1 litespeed ent edition

hello, I just noticed I can’t send or receive emails at all from cyberpanel v 1.9.1 litespeed ent. CentOS 7 vps

I have been using upcloud for a while now and port 25 is open not blocked, I had requested this for another vps i have with them using cPanel
so I am testing out CyberPanel on this new vps but the email function is not working… I added a domain then added an email and then logged into email via WEBUI in cyberpanel and created an email and sent it to my gmail account, then i logged into gmail and I sent an email to my email@mydomain.com i have not received any emails from either one

i also did a test: I sent an email from myemail@mydomain.com to the same myemail@mydomain.com and it worked within the WEBUI rainloop. but incoming or outgoing emails do not work.

ok I deleted my vps and I did a fresh install of cyberpanel 1.9.1 withoutinstalling CSF or spamassasin.

just added ns1 ns2 creating nameservers then added hostname.mydomain.com then added mydomain.com gave them both SSL and SSL for Hostname

so just fresh install and email is working now, sending and receiving…

now to try install spamassasin and see if still works and then try to install csf again and see if they still work. will update

installed CyberPanel (with OpenLiteSpeed) version 1.9.1 CentOS 7 VPS

I was having lots of issues not being able to save rewrite rules, not being able to send emails or receive emails after installing cyberpanel and installing CSF and spamassasin.

  • So I started from scratch again> upcloud.com created a vps 2 cpu 4gb ram after cloud was spun up I went to my vps > [Network] in upcloud.com panel and I set my Reverse DNS Name to my hostname (example) hostname.mydomain.com

Then I logged into ssh and ran this code> update yum

then I started to install cyberpanel.

sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)

once finished I logged in from https:// ip:8090

then i went to cyberpanel > DNS > CONFIGURE DEFAULT NAMESERVER
added ns1.mydomain.com ns2.mydomain.com and clicked SAVE
then went to DNS> CREATE NAMESERVER
enter my domain.com
ns1.domain.com IP address of my server
ns2.domain.com SAME IP of my server clicked SAVE.

Then I went to websites > Create New Website> added > hostame.mydomain.com
selected all Additional Features
SSL yes
DKIM Support yes
open_basedir Protection yes
click SAVE

then I went again to websites > Create New Website> added > domain.com without the www
selected all Additional Features
SSL yes
DKIM Support yes
open_basedir Protection yes
clicked SAVE.

then I went to SSL > Hostname SSL > ISSUE SSL FOR HOSTNAME
select from the dropdown your hostname.domain.com
click Issue SSL

then go to SSL>Manage SSL > Click dropdown select yourdomain.com Issue SSL

then go to Email > Create Email> select your domain in dropdown and add your email account(s) you want.

after creating all your email(s)
go back to SSL>MailServer SSL >ISSUE SSL FOR MAILSERVER select your domain.com in dropdown and click Issue SSL.

Now go to email > access webmail and login to your Webmail and send away… should work to send and receive.

NOTE: some providers block port 25 so check with your hosting provider to see if they will open port 25 for you if its blocked and if you cant send or receive emails. then it should work.

also if you go to Websites>List Websites> find your domain and click on manage link

now scroll down and click on rewrite rules and select the drop down to add the template rewrite rules, then click save and should save and be correctly setup.

I wrote down my steps I took to install cyberpanel and make sure it worked for me, not sure if you need to follow them in the same order, one after the other but, my first install was a mess, so I tried again and this one worked.

Note: I do not have Spamassasin or CSF installed, first install I had installed CSF and Spamassasin so not sure if one of those was the culprit for not sending or receiving emails or not being able to setup rewrite rules in cyberpanel.
I guess I can test and update here again. :slight_smile:
regards,
Spiro

ok turn on Spamassasin and errors start there after trying t o send emails… if you dont opt for spamassasin your emails will work

I am going to try on UpCloud VPS now, I think there are some changes in Centos 7.7

My result without Spamassasin → Spam Test Result

With Spamassasin → Spam Test Result

With csf → Spam Test Result

This is fresh install of CyberPanel on UpCloud Centos 7.7

[root@cyberpanel ~]# cat /etc/redhat-release 
CentOS Linux release 7.7.1908 (Core)
[root@cyberpanel ~]#

To set up email perfectly I follow the procedure mentioned here → Achieve 10/10 Email score with CyberPanel! - CyberPanel

Rewrite rules fetch/save also working fine for me. I am not sure what trigger all those errors for you.

If you have any other server with same results, you can create ticket and mention ticket id here.