I can't send emails to Gmail accounts due to IPv6 PTR records configuration

when i try to send any email to Gmail account i receive this email from google titled

Undelivered Mail Returned to Sender
This is the mail system at host outletegy.com.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

muhamed.oka@gmail.com: host
gmail-smtp-in.l.google.com[2a00:1450:4013:c02::1b] said: 550-5.7.1
[2a01:4f9:c010:82bf::1] Our system has detected that this message does
550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and
550-5.7.1 authentication. Please review 550-5.7.1
Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more information 550
5.7.1 . fj1si12679963ejc.814 - gsmtp (in reply to end of DATA command)

i edited my reverse dns for server ip address but i don’t know what to do with ipv6

can anyone help I am a beginner … i am on the free plan

I know this is a few months old, but I ran into the same problem and found a simple solution here, which worked for me. You just go to list emails, select the domain, and you’ll see a message with the “Fix Now” option. Clicking that seems to have fixed the problems for me.

I couldn’t figure out how to edit the above post, but ironically this post came up when I was searching for the same problem still occurring. After a lot of trial and error, I think I really do have it solved now - and it is not a particularly simple solution. It turns out that cyberpanel does not natively support IPv6

I don’t know if gmail always looks to verify an IPv6 address as the sender, or if it is only occurring because the server I provisioned has an IPv6 address. I had to add the IPv6 address manually into cyberpanel, add the domains I’m sending email from to that listener and then add the IPv6 addresses into my DNS settings.

I summarized my steps in this post about fixing the IPv6 error message from bounced gmail messages. Hopefully it helps people if they come across this same problem.

I don’t know how complicated it would be for cyberpanel to natively support IPv6 as I think that is supposed to be the future for IP addresses.

I had the same problem. I guess whole issue was that I selected “Create Mail Domain” when created a website.
My server IP has rDNS of example.com, but CP created mail.example.com as email sender. Gmail doesn’t like email coming from mail.example.com and rDNS pointing to example.com

My solution was edit /etc/postix/main.cf by adding a new line myorigin = example.com next to existing myhostname = mail.example.com and of course Postfix server restart.

Note: myorigin defaults to myhostname in Postfix config