https:// does not work

Hi I am facing a weird situation here.

when I add a website to cyber panel, it suggest me to add website without www infront of it as it claims to be adding it by itself.

So when I add a website using “domain.com”, ssl does not work on “https://www” address and only works on “https://”

Now if I add website as “www.domain.com” then ssl works only on “https://www” and does not work on “https://”

I am trying to set it up in such a way so that all my traffic goes to “https://www” no matter what user types in the browser.

I am able to achieve that by adding website as “www.domain.com” and set rewrite rules to “non www to www”. But when I visit website on “https://domain.com” it is showing me as non secure.

I wonder what am I doing wrong?

Thank you.

Hi, I have had issues with what your saying and it ended up being cache in my browser and ISP.

Just add the domain as it says without the www
Try to clear your history - browser cache. And also try it from your mobile phone after clearing cache and your history in browser…

Also if you can download Opera browser it has a setting to turn on VPN - this will help to make sure SSL is working a cache is not the issue, it has helped me to make sure issues with SSL and or propagation of domains work correctly.

Hope this helps

Regards,
Spiro

PS what server you have ? CeontOS 7 ? Version of CyberPanel ?

@tathspts I just found this in CyberPanel Docs, maybe this will help solve your issue