HTTP 3 QUIC + ipv6


I have fresh install of cyber panel and I have testing my server with two different domains. Now I noticed when I was testing HTTP/3 that my ipv6 is not connecting with QUIC.

Test that I used is
my server: (ipv4: ipv6: 2a01:4f9:6a:4ae8::2)

my other domain with same results:

When I select advanced and put my ipv4 address test is successful, but fails with ipv6 error: QUIC connection could not be established

Advanced tab shows right ipv6 address.

I have tried to temporarily disable all firewalls (CFS), I also have modsecurity installed. And I have opened ports for UDP 443 on both ipv6 and ipv4

Cyberpanel installation is under week old, so it is quite fresh.

Tried to search from google and forums, but didn’t find anything.

I am new to cyberpanel and ipv6 is kind of new to me as well so any help is apprised.

this is results with ipv4:
HTTP/3 Check - (

I don’t know where to look this problem anymore.

Now I got it working. First time configuring Litespeed so didn’t find it first, but it is quite obvious when I found it.

So what I did was looked from litespeed config under “Listeners” and I noticed Listeners are only set for IPv4. So I just added IPv6 listeners and used same configuration as in IPv4.

Now it works with IPv4 and IPv6. Here is some screenshots to help others:

and remember to add Virtual Host Mappings:

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.