How to upgrade php8 cyberpanel

How to upgrade cyberpanel php8. Please support me.

Thank for all.

Rerun upgrade to v2.0.3

And it will be added automatically.

I am already running Latest CyberPanel v2.0.3 but don’t see option for PHP 8 yet. @CyberPanel

Type your comment> @cloudrider said:

I am already running Latest CyberPanel v2.0.3 but don’t see option for PHP 8 yet. @CyberPanel

Do you use this command?

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

I have php8 showing on the “select php version” list, i have selected php8 on the “change php” option of the site manager but sites are showing old php7.4 , any idea why?

Replying to myself… restarting php and everything is working.

Type your comment> @Diego said:

Replying to myself… restarting php and everything is working.

I have the same problem, unfortunately reloading did not help, php 8 is displayed but when selecting and trying to edit options cat error: /usr/local/lsws/lsphp80/etc/php/8.0/litespeed/php.ini: No such file or directory

Hi guys, I have the samme issue as @sergii
selecting EDIT PHP CONFIGURATIONS → Advance ->php 8.0

Same here: cat: /usr/local/lsws/lsphp80/etc/php/8.0/litespeed/php.ini: No such file or directory

is there any solution? still the same for many days. and php 8 supposedly works in the cyber panel from 2020

After updating selecting PHP8 is not so great, if you check server status on WordPress it needs a PHP module which package doesn’t install. imagick does nothing when installed.

After upgrade from cyberpanel 2.0.3 to cyberpanel 2.1.1, there is a php 8 in UI, but not install lsphp80, so I run apt install lsphp80 (ubuntu), and restart server. Then php 8 runtime works well. (I don’t knwo why upgrade cyberpanel not install lsphp80, but we can install by ourselves)

Thank you @timhuang that worked for me too!

I wish this worked for me. No combination of command-line upgrade/install instructions that I’ve tried give me a cli PHP version of anything other than 7.4.21, including @timhuang 's procedure above.

I finally got a php -v of 8.0.10 (cli) by following the instructions here: How to install/update PHP 8.0 (Debian/Ubuntu) • PHP.Watch

Hi,

The same issue. running latest version of cyberpanel and ub os
Tried upgrading and reinstalling still PHP 7.4 and above not available.
PHP >> advance >> 8.0 “cat: /usr/local/lsws/lsphp80/etc/php/8.0/litespeed/php.ini: No such file or directory”
tried installing 8.0 “How to install/update PHP 8.0 (Debian/Ubuntu) • PHP.Watch
still the same.
Can somebody help me with this??