How to uninstall spamassasin on Centos 7

Hi, I’m using windows and cyberpanel I only saw instructions for ubuntu and other OS. Is there some way for me to remove spamassasin? Thank you

There must be some solution? Please, it’s absolutely destroying the server CPU

Hello @kyu

Which server os ?

Hey, its CentOS 7 64bit with CyberPanel

Is this a new installation?

Server and website about 2 months old now. Installed spamassasin yesterday


$ yum remove spamassassin

Using this server os is discouraged for new installations. Your installation was setup after the caveat came out 01 - Installing CyberPanel


hey thanks, but that the thing I don’t understand do i do that on my windows prompt? or where do i run that command?

Install bitvise ssh for windows and check your roor/sudo username and password from your server provider and run the command when you connect to your server

Ah ok, thanks a lot, will do that now

For centos you have to nuke these directories and their files

rm -rf rm -rf /etc/mail && rm -rf /etc/mail/spamassassin && rm -rf /etc/sysconfig/spamassassin
rm -f /usr/bin/spamassassin
rm -f /usr/bin/spamc
rm -f /usr/bin/spamd
rm -f /usr/lib/systemd/system/spamassassin.service
rm -rf /usr/share/doc/spamassassin-*
rm -f /usr/share/man/man1/sa-awl.1.gz
rm -f /usr/share/man/man1/sa-compile.1.gz
rm -f /usr/share/man/man1/sa-learn.1.gz
rm -f /usr/share/man/man1/sa-update.1.gz
rm -f /usr/share/man/man1/spamassassin-run.1.gz
rm -f /usr/share/man/man1/spamassassin.1.gz
rm -f /usr/share/man/man1/spamc.1.gz
rm -f /usr/share/man/man1/spamd.1.gz
rm -rf /usr/share/spamassassin
rm -rf /var/lib/spamassassin
rm -rf /var/run/spamassassin

Please think of changing os to ubuntu 20.04 or AlamaLinux 8.3 in future

Am I doing this wrong? It says I logged in with the hostinger ssh data, then i clicked new terminal console pasted this but seems nothing is happening?

Should I run the commands somewhere else?

It shows yyou were prompted to run update and you agreed to run the update. You have to wait for system update to finish to uninstall spamassassin

1 Like

It’s not doing anything in the terminal console? Even the update just stays at 5% I left it open for 20mins not showing anything but 5%

‘$ yum remove spamassassin’ and enter also does nothing just opens new paragraph?

If i delete spamassasin folder in SFTP window? Would that do the trick?

That has nothing to do with spamassassin or cyberpanel. That is related to hostinger vps. Contact support for help.

No I was wrong last reply, I just had to wait a bit longer, not used to command prompts, it erased it now. It just needed yum remove spamassassin without the $ sign

To erase these do I run a command or manually erase from folders?

Run the commands line by line

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.