How to setup quic.cloud cdn and how to change url to cdn on cyberpael

How to setup quic.cloud cdn and how to change url to cdn on cyberpael

Hi,

please check this

https://docs.litespeedtech.com/lscdn/onboarding/

Best regards,

Does quic.cloud cdn only works with litespeed enterprise or is it available to openlitespeed installations as well !

@cloudrider You can use quic.cloud with openlitespeed.

@cloudrider said:
Does quic.cloud cdn only works with litespeed enterprise or is it available to openlitespeed installations as well !

You can use QC with any other we server, enterprise ,OLS, Apache… etc

Thanks for the info.

Question to complete my Cyberbanel, Litespeed Ent and Quic.cloud setup.
Domain registered at Cloudflare, have the two CNAME records

CNAME mydomain.com points to cxxxxxx.tier1.quic.cloud
CNAME www points to mydomain.com

I have my domain running through quic.cloud (amazing fast!) just fine.

Problem: Since I have no A record now, only the two CNAME records how do I secure the access to my cyberpanel install? I can access is with the https://ipaddress:8090 but not
https://mydomain.com:8090

I know this is probably a simple fix that Im just missing. There is not a lot of info out there about this. Is it in the quic.cloud login area?

A few months ago I did not know anything about web servers, websites, etc. Just how to browse to one and use it. I managed to learn enough to build my own server at my location, get dedicated IP, setup my DNS, learn some about wordpress etc. Have just put this quic.cloud cdn part off until last.

Thanks for anyone willing to help

1 Like

Hi, I have the same issue as @dgswim
After setting Quic.cloud I can not access to my Cyberpanel anymore, I mean the address is not resolving.
I have Cyberpanel and my site on same domain.

Hi guys, any help? :blush:

same here! after enabling the quic.cloud no longer able to access my cyberpanel :8090 even with enable bypass the cdn!

I am facing the same problem. Did anyone of you guys find a solution? @Wyzzy @dgswim @Ta2ta2

Thanks.

@chikar i ditched the while quic all together. Happy with Cloudflare.

1 Like

Cloudflare doesnt offer proper cdn service + full page dynamic cache

Check this out

I’m also having trouble with this. I set up LS Cache and Quic.Cloud, configured the DNS and then it says waiting to issue new SSL. After 15 minutes, it tries and fails and then needs me to recheck the DNS and issue SSL again.

It thinks that my SSL certificate expired 6 months ago, because I have had Quic.cloud disconnected since then.

image

Yet in CyberPanel, I have 89 days left on my Let’s Encrypt SSL cert.

image

So, there’s obviously some miscommunication going on with the server and/or SSL.

I don’t know what to do to fix this.

I’ve somewhat fixed this now, but not completely or sustainably…

First, I insert my SSL cert and private key into the boxes at the bottom

These can be found via SSH at /etc/letsencrypt/live/

However, it wouldn’t accept the certs, saying that they don’t cover my domain name. The only thing that could make sense for that is that the keys only cover the root domain, not the www.domain

So, I turned off “Map Both” and inserted the keys again and it accepted them.
image

Then I re-verified the DNS and (I think) waited for the SSL to get checked again. Now it is all verified.
image

And when i visit the site, it is now connecting with SSL rather than giving me a warning on every page load about an expired certificate.

However, there are three problems:

  1. When I set it to System-Generated SSL certificate, it tries to reissue one and the problem starts over again. I dont want (or even know how) to set it manually going forward.
  2. I still cant access CP via domain.com:8090
  3. When i access the site via www.domain.com, I get this error

Ok, I have resolved these issues and will leave my above comments for other’s reference.

I deleted the domain from Quic.cloud and re-initiated the process. Everything works, EXCEPT hostname SSL for cyberpanel - which is the same as what everyone else has reported in this thread.

What can we do about it?

Ok, I’ve solved the problem with a bit of guidance from @qtwrk at Quic.cloud support.

Since your domain is routed to the Quic.cloud CDN, it cant go to port 8090.

  1. In CyberPanel, you can go to the website in question, add a domain, call it something like panel.domain.com.
  2. Set up your DNS with an A record for panel that points to the server’s IP address (or, if you are already linked to Cloudflare, it’ll happen automatically upon subdomain creation).
  3. Issue a hostname SSL for panel.domain.com.

You should now be able to access Cyberpanel from panel.domain.com:8090. You don’t even need to put anything in the subdomain.