How to prevent PHP from going idle

The first time loading my website takes too long and I know that’s because of PHP Max Idle Time, I’m running a low-budget PPC campaign. I’m afraid I will lose some of my visitors due to page load, and because the low-budget, visits are far from each other, the process must go idle before each visit, which will cost me high. Please help me reduce the page load for every visit.

I really appreciate any help you can provide.

Hello @Cyb3r

Adjust the PHP Max Idle Time setting under OLS/LS WebAdmin console Configuration → External App → your_external_application

This controls how long a parent processes can stay idle before being terminated.

Hello @josephgodwinke,

What’s the best value for my case? Should I increase it or decrease it?

Edit: Is it safe to set it as -1?
Edit 2: It’s already set to -1 as a default, so it shouldn’t be stopped, why is it stopping?

Appreciate your help.

Default value is usually 10 seconds unless overidden by other configurations such as mode. You can set this to a very large number, such as 5000 , to prevent LSPHP from being stopped by the server too quickly.

Is it safe to set it as -1?

Yes setting it to -1 means it will not be terminated by server

Thank you @josephgodwinke!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.