How do I restore CyberPanel's self-signed SSL?


A couple of days ago, I accidentally deleted (or they were just gone) the certificate files com webadmin.crt and webadmin.key from “/usr/local/lsws/admin/conf”. They seem to be symbolic links, so I’m not sure where they were located before.

Because it broke my access to Litespeed’s admin panel, I had to generate new self-signed certificates. I added them to the same folder with the names server.crt and server.key.

However, ever since then, I can’t access CyberPanel via HTTPS (its naked IP) - but I used to. Not even if I use a domain, I think.

I appreciate any suggestions.

By the way, the error I’ve been getting when I try to access my CybePanel’s IP via HTTPS is “ERR_CONNECTION_CLOSED”.

Just try to upgrade cyberpanel and it will restore all these files if missing.

1 Like

Thanks, but I’m getting this during the “upgade”:

chown: cannot access ‘/usr/local/CyberCP/lib64’: No such file or directory
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
curl: (35) error:1408F10B:SSL routines:ssl3_get_record:wrong version number

Seems something wrong with upgarde, please check…

I updated my cyberpanel just an hour back and it was working without issues.

Login as root and run the upgrade command.

Try this code before running the cyberpanel upgrade command

sudo su -

I have restarted the server and even tried to downgrade CybePanel. But I’ve getting the same error:


The only workable solution was restoring an old backup I had of CyberPanel, unfortunately.

If anybody else knows the origin of such errors, please let us know!