How can I use CyberPanel exclusively as an email server?

I am using two servers with two different IPs for the same domain. One server has my mx record and all of my other email txt records, and my other server serves my website. I have set this separation of concerns intentionally. How do I shut down the PHP and web server and stop it from serving the default website on the email server? It is interfering with my other website, so I have temporarily removed the A record for the domain from that server, but now my reverse DNS does not work for my emails and they are being rejected by Gmail and Outlook. I’m hoping somebody knows some sort of simple solution to this. Any tips would be greatly appreciated. Thank you.

Hello @0xj

This is not something you want to do since an upgrade would not be possible.

How? Kindly explain

Why would I be unable to upgrade my email server if I shut down the web server in it? I don’t understand how the two are linked.

What is happening is I have two VPS, one serving my website and one serving my emails. The other day I noticed when going to my domain, it was pulling up the default cyberpanel website from my email server instead of my actual website, so I removed the A record from my email server for the base domain and only left the mail.domain A record with all of the other DNS records. The emails work fine, but it will not make it past the spam filter. I was getting errors from saying I did not have a reverse DNS.

I went ahead and readded the A record to my email server for the base domain for my website, and it seems to not be interfering with my real website on the other VPS with the separate IP, but I’m not sure for how long it will do this. I am having issues making it past spam filter, even though I’ve set up:

A record for base domain + mail.domain
MX record for mail.domain
_dmarc and _domainkey dmarc,
and even a bimi record.

I’m passing most scores on test websites, and I just want to make sure I can use this to send emails to people using Outlook. As of right now, Outlook emails are rejecting my emails and I’m not sure why. My reverse DNS is set up with my base domain and the A records point to both IP’s (web server and email server, two separate IPs).

Maybe you know something I’ve been missing in my research over the past day or so. Thank you for your help, this has been a lot for me to learn about in one day.

You need to add a rDNS ptr record where you purchased your emails server vps from. Check your service provider docs. This is not related to cyberpanel

Seems you did your due diligence. Why dont you post results of all your checks and if you prefer blur out personal info.

What errors are you seeing ? Outlook is rejecting emails from being sent ? Post screenshot or error message.

Yes, I set up reverse DNS with my VPS. It stopped working when I removed the A record from my email server for the base domain. I re-added it, but now I’m hoping my two different A records for the base domain don’t get mixed up again and send me the wrong website from my email server with the default CyberPanel website. As of right now, I am getting 10/10 on and the only warnings I am getting are for making my dmarc settings a little better and adding a VMC certificate. I’m making it past Gmail spam filters, just not Outlook. I am referring to the fact that Outlook emails are not receiving them in the inbox. They send out just fine using Thunderbird.
Screenshot from 2023-03-05 12-57-02

So I really can’t turn off the default website in CyberPanel? I really don’t need it to be there for the email server. All it does is serve emails. The other one is handling the website.

What you are trying to achieve is futile. How to Host Your Own Email Server (for free) - YouTube

As you see in the youtube video you cannot separate cyberpanel default operations from mail server. For such cases I would recommend you check alternatives.

Okay, thank you, I really appreciate your help today. I’ll look into this.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.