How can create Sub/Child domain using Parent Domain

Hello Advance,
We would like to create a subdomain for our parent domain- it’s already created and we looking to add a sub/child domain- and we looking to add sub domain path /home/ . Please explain the steps for creating a subdomain or sharing video links.

Please share your idea and support. We are using Cyber Panel 2.3

1 Like

If the main website is hosted somewhere else maybe you can add it to CyberPanel using DNS A Record.

Hi Tobsowo,
Thanks for your quick response.
Parent domain- webespire dot com and sub/child domain- blog.webespire dot com we looking to upload on the same server/ Same IP/same Cyber Panel it’s not on a different server.

We have created but it does not redirect on blog.webespire dot com it’s redirected to blog.webespire dot com/403.html and the application page doesn’t load. 403.html page show an error page.

I am not sure what’s an issue and what wrong steps we refer to. Thank You.

How did you create the subdomain from the domain itself or you created it as a new website?

Try deleting the subdomain and create it as a new website. Dot use the subdomain feature under the main domain.

Hi Tabsowo,
We have tried both ways. I have deleted sub domain and followed the below steps.

Step 1

Using Create Website, i go Create New Website - CyberPanel

Filled Select Package, Select Owner, Enter Domain name- testing4 dot webespire dot com then filled email, select PHP and tick SSL

After creating a website, i have added DNS for testing4 dot webespire dot com and i try to open testing4 dot webespire dot com and it shows a preview but when i try to open Url- testing4 dot webespire dot com it’s open 403.html page and page don’t load.

Step 2

Using create the subdomain from the domain itself

I go list website Websites Hosted - CyberPanel then go a website control panel [saiprintopack dot com - CyberPanel]( dot com) then click on add domain choose a domain name from drop-down saiprintopack dot com enter domain name- testing4 dot saiprintopack dot com and enter Path: /home/saiprintopack dot com/public_html/testing4 OR Path: /home/saiprintopack dot com/public_html/testing4 dot saiprintopack dot com after that select PHP and choose SSL click on Create Website and open Url- testing4 dot saiprintopack dot com it’s open testing4 dot saiprintopack dot com/403.html page and page doesn’t load.

I am not sure, what’s wrong follow our steps, and step 1 or step 2 is best for creating a subdomain. Please guide us.

Thank You.

just use add domain and point the folder/path
then restart litespeed service

@shoaibkk : if im not wrong this (restart litespeed) cannot be done by user… why not add “Restart service” automatically everytime add website/domain ?

@MyIDKaTePe Thank you for your response

i added one child domain under one of the master domains and assign the path after that restarted all Litespeed services and rebooted the server but the child domain is still not loaded on the browser. Child Domain is [login5 dot worldtrackgps dot in](login5 dot worldtrackgps dot in/index.php)

add record IN A

A Records already added. Please see the top attachment.

One Error message is shown for the subdomain. Please see the bottom attachment.

It’s redirected on the page- 403.html and does not load anything. Link-

restart the litespeed services ?

filemanager : fix permission ?

filemanager : add newfile abc.html
then try to call it from browser

cleanup the htaccess ?

@MyIDKaTePe It’s working for url- [Login - CyberPanel (worldtrackgps dot in)](login5 dot worldtrackgps dot in:8090/) but not for [Login - CyberPanel (worldtrackgps dot in)](

Yes restart litespeed services, fix permission 756, added newfile abc.html, open url in new private browser, delete htaccess there is not any htaccess file.

It’s redirected on [login5 dot worldtrackgps dot in](login5 dot worldtrackgps dot in/403.html) PFA screenshot.

remove all htaccess

@MyIDKaTePe Folder no include any .htaccess file. Yes folder available 1 .htacess files.

if im not wrong…

public_html/.htaccess will work until sub/sub/sub…/sub

using cloudflare ?

success ?

@MyIDKaTePe i deleted.htaccess No we don’t use Cloudflare.
no URL- does not load in a private browser.

No, we don’t succeed and the page redirects on page.


try do this

if you want to get help
you should follow all instruction that perhaps you think unnecessary but if you want to get help… at least… follow the instruction

why ?
we are here all community, human being not have mambo jambo spell to solve everything problem without enough information.

@MyIDKaTePe i have to follow all your instructions but the URL- login5 dot worldtrackgps dot in/ continuous redirects on [](https://login5 dot worldtrackgps dot in/403.html) i am not sure why it’s happened.

PFA continuous redirects screenshot.

Please advise next steps.

check at domain/website … are the login5 is there…
check the DNS inside add/remove DNS…
after everything is ok…

call: https://yoourdomain.tld/abc.html from igconiqto mode

@MyIDKaTePe Add/Delete DNS section this error shows for the subdomain.

Please verify and Advise.

Subdomain already listed in Child Domain Sections.