Gzip is not working properly on WordPress

I have a wordpress website, and I’m using a plugin to do a gzip compression. but it is not working, it gives me this error:

Gzip is not working properly:

Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX). Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied. If re-checking and restarting does not resolve, please check with your host or open a support ticket.

My server Gzip Config:

Hello @shadi

Can you confirm you have the module Unable to Use ZIP Extension - PHP 8.0 - #4 by josephgodwinke

Have you tried to add zlib.output_compression = 1 to your website’s php.ini

Also look at this Unable to Use ZIP Extension - PHP 8.0 - #7 by josephgodwinke


litespeed_wiki:config:gzip-compression [LiteSpeed Wiki] Note: Enable Compression and Enable GZIP Dynamic Compression are enabled by default at installation.

I can confirm that I have a ZIP extension installed and enabled for PHP 8.0:

And I have added zlib.output_compression = 1 to my php.ini through cyperpanel for PHP 8.0.

I have also a question, is this problem somehow related to my other problem of not be able to set browser cache through .htaccess?