Gmail POP3 POP Server issues.

Hello Team,

Question 1:

My Admin account is abc.com, and my Client account is xyz.com

I want my Client account to use the POP Server → xyz.com (Port 995), but not successful, Gmail will be warning me below message


Unable to establish secure SSL connection to xyz.com[ Help ]
Server returned error: “SSL error: ok Hostname “xyz.com” doesn’t match any SANs: “abc.com”, “www.abc.com””


And I also tried to use non-SSL (Port 110), Gmail is also warning me


There was a problem while connecting to xyz.com
Server returned error: “SSL protocol error. Please try disabling SSL, or contact your other provider to verify the correct port settings.”


May I know can I use my Client account (xyz.com) as the POP Server in Gmail?

Question 2:

Also, I found and tried that I must need to enable the CSF to use the Gmail POP3 function, if I disable CSF and use CyberPanel Firewall, the Google will not pass it. ?

Many thanks =)

This guide will help you set up email on Gmail

Especially at the end, you will find the information you need but recommended to read full tutorial.

Hello, Nice to meet you!

I followed your provided teaching and my current rDNS entry (IP address) is pointed to my Admin account (abc.com).

But my current Client account (xyz.com) to use the POP Server → xyz.com (Port 995), is also not successful, Gmail will be also warning me below message


Unable to establish secure SSL connection to xyz.com[ Help ]
Server returned error: “SSL error: ok Hostname “xyz.com” doesn’t match any SANs: “abc.com”, “www.abc.com””


May I know is it not possible to use xyz.com as the POP Server?
Or Can I disable the SSL, to let the Client to use non-SSL (Port 110)?

Thanks for your support again! =)

When you configure POP on Gmail you can use abc.com as a POP server, before using this domain make sure to issue SSL for it 2 - SSL For PostFix/Dovecot - CyberPanel

You can use abc.com to configure xyz.com too. So while adding email from xyz.com use abc.com for the POP server along with port 995

Understood, thank you so much for your support =)

Hi, i have problem with Gmail .
My hostname (hostanme -f) : mail.domain.com
my mail : aaa@domain.com
DNS MX : mail.domain.com

i have 10/10 on mail-tester.com
I create Let’s Encrypt SSL for MailServer (Postfix / Dovecot)

now in gmail :
POP mail.domain.com port 110 no SSL = „[AUTH] Plaintext authentication disallowed on non-secure (SSL/TLS) connections.”

POP mail.domain.com port 110 with SSL = „SSL protocol error. Please try disabling SSL, or contact your other provider to verify the correct port settings.”

POP mail.domain.com port 995 no SSL = “No route to host”

POP mail.domain.com port 993 with SSL = „SSL error: ok Hostname “mail.domain.com” doesn’t match any SANs: “domain.com

POP domain.com port 993 with SSL = „Missing +OK response upon connecting to the server: * OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE LITERAL+ AUTH=PLAIN] Dovecot ready.”

POP domain.com port 993 no SSL = „Connection timed out: There may be a problem with the settings you added. Please contact your other email provider to verify the correct server name and port.”

in Achieve 10/10 Email score with CyberPanel! - CyberPanel
i found info : “Choose port 995.”
BUT only 25, 587, 465, 110, 143 and 993 is open on firewall .

What should i do ?
Change hostname to domain.com?
Open 995 port?

help me please.

Same here.

Can’t understand HOW to connect via POP and SMTP trough SSL.

Docs are missing. Any help from Cyberpanel creators?

Use the following to add SSL for all mail domain and fix auto-discover too