Getting frustrated by cyberpanel

I had issues with SSL reverts to self-signed every Sunday at 00:00hours GMT and I gave up finding a solution when I couldn’t get one from the community and I resorted to staying up from 11pm Saturday till Sunday so as to issue back the SSL certs when they revert because I have more than 100 sites in my server.

My mail server failed to work yesterday and this made me to update cyberpanel as it showed I wasn’t on the Latest Commit. The mail server started working but I don’t think it was due to the upgrade

Now I’m on the latest version and commit but I’m stuck at the Login page. I can’t access the control panel. All SSLs have reverted to selfsigned and I can’t login to re-issue them manually.

Clients are now on my neck as the SSL warnings are scaring away their visitors.

PS: Google Authenticator is not enabled on my account.

Cyberpanel is not for developers who has no experience in system administration.

  1. For now find the post for disabling the Google authenticator in cyberpanel.
  2. Disabled the crons related to the SSL renew.
  3. Create a script or manually copy the working SSL files from letsencrypt SSL folder /root/
  4. Restart the webserver service.