Fresh WordPress website unable to upload Plugins 403 Forbidden

I have installed wordpress website from cyberpanel dashboard. But unable to upload plugins. I get 403 forbidden error.
I wanted to check error logs with file manager from logs folder. But when i try to download logs also i get same 403 error.
I checked owners all look ok that none of them root all website owners.

click on rewrite rules & just save them
error will go away

Hello, just tried clicked to http–>https rewrite rules. Still same. Nothing changed.
The last change i made may cause the problem but also where it was i can not remember .
I did Config Security and Firewall check
Under Ssh/Telnet there was 2 warnings which 1 of them i fixed:
It was something about Domain Dns passwrod connection enable or disable. I changed it somewhere in some config.
That warning then disappeared and i went in score from 62/65 to -63/65
I have a feel that my causing problem.
Strange about that error is i don’t get 403 error only in wordpress. I got it when by cyberpanels file manager try to download error log file!

I get 404 error when trying to download access log file. I saw that address is wrong also as i marked on image.
/… /

Wow! Why does this work? Had set up a staging site and it worked fine except no images were being loaded (403 on all of them). I tried everything, file perms, plugin deactivation, resetting htaccess, etc … I came across this post by accident and tried it not thinking it would do anything but sure enough… it fixed it. lol.

Sorry to post on an old topic. I’m just really curious.