Fresh install on Ubuntu 22. Litespeed cant start after reboot

I have tried to install Cyberpanel numerous times, and on several different machines, and always get the same issue.
I am trying to install onto a fresh install of Ubuntu 22. I want to install it inside and LXD container, but I have tried Cyberpanel inside LXD container, and on bare-metal Ubuntu installation, and get the same problem.

Before installing Cyberpanel, i take the following steps:

  1. set static ip address with netplan
  2. apt updade && apt upgrade

After the cyberpanel script completes, I can access https://my_ip_addr:8090 as soon as the install is complete, but once the server is rebooted, litespeed cannot restart. There are no mentions of why in the journalctl nor the install log.
It just says “Job for lscpd.service canceled.”

I am not familiar with Litespeed, and have previously always used nginx or apache … is there some other sequence I need to follow to restart litespeed other than “systemctl restart lscpd” or " systemctl restart lsws" ?

I have also tried to Manually set up virtualevn, with these commands:

source /usr/local/CyberCP/bin/activate
pip install --ignore-installed -r /usr/local/CyberCP/requirments.txt
virtualenv --system-site-packages /usr/local/CyberCP
systemctl restart lscpd

but the problem persists.

Has anyone else encountered this problem?

I have been experiencing this for many weeks but unfortunately, the developer couldn’t help.

I tried again recently and after a successful install, the URL works but when you restart the server which the terminal ask to, the server is down.

cc: @usmannasir @shoaibkk

i just created a fresh Ubuntu 22 server and then rebooted that many times but always the lsws is up and running also i tried start, stop, restart for different services and all going well

I’ve checked your server and it is lxc

root@Cyberpanel2204:~# systemd-detect-virt

We do not support LXC. KVM, openvz and bare metal are only supported.

My current 20.04 is on LXC and working maybe it’s 22.04 that do not support LXC.

If it is working good, but we don’t officially support LXC. If you have any problem with KVM, OpenVZ or bare metal servers, happy to look for you.

I have the same problem, with my centos 7 server. got my cyberpanel install successfully but is not loading. Do I need to restart my Instance?

The issue is it happens due to the fstab entries added by Cyberpanel after install. Choose no to when ask for reboot after cyberpanel installed, then open /etc/fstab and comment all lines added by cyberpanel. Then reboot it works fine. Not sure any issues or stability of this, but it works at least with this method.