Force server to use external SMTP for notification emails

Is there a way to force server mail notifications to be sent from a specified external SMTP host?

I’ve setup and verified an external SMTP provider, both in the Hostname → E-mail Marketing → Hosts section and also in Logs → Server Mail.

However, email notifications continue to be sent from localdomain and consequently either don’t get delivered or get tagged for spam.

Has anyone found a solution?

Login to rainloop admin and set your smtp configuration there.

I’ve done that. I’ve added the Override SMTP Credentials plugins, and added the SMTP credentials. I’ve added the Hostname domain to the Domains in Rainloop, as well as the domain of the first website ( that I’ve created.

When I created the first website, the server notification was sent via the external SMTP service. However, when I attempt to generate a Wordpress password reset from the first website created, it’s reverting to sending via localhost, and the email ends up in spam

Any ideas?

Wordpress by default uses php mailer function. To overcome this, you can use plugins like WP-SMTP mail or Fluent Mail and force all mails from smtp mailserver.

Hi there.

Thanks very much for your advice. That’s actually what I’ve done as a workaround. I was hoping that I could force the CyberPanel server to handle the WP transactional emails (eg password reset), but apparently not. I’ll just have to install an SMTP plugin with each WP install.

Php mailer and smtp mailer both are different. Wordpress by default uses php mailer option for sending mails which can be changed using plugins.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.