Filtering Spam in RainLoop, AutoReply and Email Filters with Sieve

Adjust the spam level settings under spamassasin to make the required level of security

1 Like

I increased the required_hits and required_score values. The default is 5. I put 10, then 20, 1000… and it didn’t work!

Have you gone through this article? This may help

Hi, what is required hits vs required score?

Mails remain working after implementing this article.
Filtering options are now showing up.
Problem is filter created in rainloop login of any particular email account but that filter rule gets applied globally to all Email accounts of all domains running on server.
This is a bug. Please suggest the fix.
Thank you.

1 Like

I just tried my method again, and now it’s not working on a clean install.
I also tried this method and the same result Any suggestions @die2mrw007

Got any advice on the issue i posted over? @usmannasir @die2mrw007

I run CyberPanel using Almalinux 8, and I’ve tried every dovecot.conf I can find.
Every dovecot.conf file fails except the default without a sieve.

I have also tried on 2.3.3-dev, same issue there.
I am clueless on what I can do to get it working.

Operating System: AlmaLinux 8.6 (Sky Tiger)
CPE OS Name: cpe:/o:almalinux:almalinux:8::baseos
Kernel: Linux 4.18.0-372.16.1.el8_6.x86_64
daemon started -- version 3.7.2, configuration /etc/postfix
dovecot --version: (9b53102964)

You guys…

Do you even read the log? Anyway just tell us the WHOLE fatal error on line 80


Here is line 80.
Here’s the whole file.
dovecot.conf -

I didn’t ask for the file, I ask what is the full error that dovecot gave, because that’s all that matters.

That is the full error.
There’s no cutoff that I could do.

What? I see it, right it’s in the log, dovecot is saying : Fatal: Error in configuration file blabla line 80 … length

What is the full error, we can’t just debug this on “…length”, you cropped that screenshot.

I took the time to send a screenshot of it, I don’t want the config, or that you think it’s right, just the full error message that dovecot printed out. It’s logged somewhere anyway, nothing else matters, dovecot will never start if it has a Fatal Error

I just ran this dovocot error log checker.

doveadm log find

doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 80: Unknown setting: managesieve_max_line_length

good, progress.

So I don’t know, install dovecot-pigeonhole? Not sure where managesieve belongs to.

Tried this, and get an error.
Not sure why it’s in conflict.

## Install dovecot-pigeonhole on AlmaLinux 8 Using dnf

Update yum database with `dnf` using the following command.

sudo dnf makecache --refresh


After updating yum database, We can install `dovecot-pigeonhole` using `dnf` by running the following command:

sudo dnf -y install dovecot-pigeonhole


## Install dovecot-pigeonhole on AlmaLinux 8 Using yum

Update yum database with `yum` using the following command.

sudo yum makecache --refresh


After updating yum database, We can install `dovecot-pigeonhole` using `yum` by running the following command:

sudo yum -y install dovecot-pigeonhole

Did not run the uninstaller.


## How To Uninstall dovecot-pigeonhole on AlmaLinux 8

To uninstall only the `dovecot-pigeonhole` package we can use the following command:

sudo dnf remove dovecot-pigeonhole

that makes sense because dovecot comes with it and those sieve are version specific to dovecot

So remove that line? Does it continue complaining? I’d be surprised that almalinux dovecot is completely broken. what does journalctl -f | grep dovecot says? Any issue loading libraries?

Doing journalctl -f | grep
Outputs nothing.
I pressed enter a few times, but nothing shows.


yeah that’s normal because -f is to follow, like you send that to the background and launch dovecot…

anyway just remove lines in the config until you get some errors that makes sense. yum reinstall dovecot? yum -y install dovecot-pigeonhole dovecot-mysql? Just look on the internet, try stuff. My dovecot isn’t broken so can’t really help.

Hello everyone.

On Centos 7, clean installation with latest Cyberpanel this tutorial doesn’t even make it to Step 1.

Anyone got any new instructions?

Followed EVERY single suggestion on this post, on other posts, and on the internet also.

The most crucial question is: Has ANYONE implemented the above on the latest Cyberpanel and latest Openlitespeed (downloaded today?). Does ANYONE on this community have implemented sieve management and sents their spam mail into their Junk folder right now as we speak? Instructions like “Do this obvious thing”, or “Why don’t you try that” are no use if the commenter have NOT implemented this in your devices successfully also.

It seems weird that all around the internet there is no proper instruction for this. Everyone is giving false or limited instructions. As a company, we had to outsource it and post a Job Request on the famous sites, because it’s been over a month that we try to implement it without any luck.

Best regards!