Filemanager doesn't work for one website only

Hello, so I have 4 websites created on cyberpanel and all are great,
however i set up the 5th website , i ticked ssl , dkim , and protection but left it without mail domain name.
and created it . I added the nameservers , linked them up with namecheap ,
so everything works!
i set up the email service , created a mail , accessed the email ( and was able to send and receive emails)

then i wanted to start editing the website …

I first tested the website and it gave me 404 error … then i went into file manager to find it completely empty , not even a public_html folder… I tried to upload a file and it went through how ever it doesn’t show up , i tried to make public_html folder , but it doesn’t show up … I tried file manager on all other websites and they all work … i tried to fix permissions , it says successful but nothing happens…

I thought perhaps i’ll log into root file manager! which is an option under server! however it takes me to cyber panel addon page online … so … i do not know whats going on

Go to Cyberpanel → List websites → File manager → Fix permissions

hey there, thanks for looking into my issue, I did press on fix permissions , it gave me a green box saying permissions fixed , however i still can’t do anything and nothing shows up.
just on this website . all the rest work fine.
also do you know why root manager doesn’t work?

It is a paid addon - CyberPanel Add-ons - CyberPanel


  1. Disable VPN or proxy
  2. Disable any blocking browser addons like script blockers etc
  3. Clear Browser Cache

okay so , I made sure there is no vpn running , or proxy
disabled adblockers and any other scripts ( used aclean copy of edge and firefox)
cleared the cache and still the same
I tried again to fix permisions and nothing

I then logged in from my phone and also same result …

should i delete and start over?!

What you can do is change the attributes of of the website directory and make the directory unmodifiable for users other than root user.


$ chattr -V -i -R /home/
$ chown -R userxyz:userxyz /home/

sorry for late reply but i reached my limit of replies / day

the owner of the website is admin, which is my account.
right now i thought maybe that could be the issue, so i change the owner, then logged into the other user ( the new owner)
tried it and nothing , ( fix permissions, clean browser)
then i reverted back the website and tried again and also nothing …
what is extremely weird is that the Email is working flawlessly! …
and also the link for the website gives me 404 not found

so i tried your method and also no change …
honestly I think the problem was that I saved my website with a Capital letter at the begninig … example :

I ended up deleting the website and making it all over again .
now everything works flawlessly thanks for you time!

1 Like