Fail to start Spamassassin ( IPv6 issues )

Hello Team,

I have followed article to install the Spamassassin, all of the files look like to install to server. But the CyberPanel interface is displayed “SpamAssassin is not installed”

Also, I can not start the Spamassassin, and display below.

========================================================
[root@carrie ~]# service spamassassin start
Redirecting to /bin/systemctl start spamassassin.service
Job for spamassassin.service failed because the control process exited with error code. See “systemctl status spamassassin.service” and “journalctl -xe” for details.
[root@carrie ~]# systemctl status spamassassin.service
● spamassassin.service - Spamassassin daemon
Loaded: loaded (/usr/lib/systemd/system/spamassassin.service; disabled; vendor preset: disabled)
Active: activating (start) since 日 2019-04-07 18:39:58 CEST; 6s ago
Process: 7002 ExecStartPre=/sbin/portrelease spamd (code=exited, status=0/SUCCESS)
Control: 7004 (spamd)
CGroup: /system.slice/spamassassin.service
└─7004 /usr/bin/perl -T -w /usr/bin/spamd --pidfile /var/run/spamd.pid -d -c -m5 -H

4月 07 18:39:58 server.carriechan.com systemd[1]: Starting Spamassassin daemon…
4月 07 18:39:59 server.carriechan.com spamd[7004]: server socket setup failed, retry 1: spamd: could not create IO::Socket::IP socket on [::1]:783: Cannot assign requested address
4月 07 18:40:00 server.carriechan.com spamd[7004]: server socket setup failed, retry 2: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:01 server.carriechan.com spamd[7004]: server socket setup failed, retry 3: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:02 server.carriechan.com spamd[7004]: server socket setup failed, retry 4: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:03 server.carriechan.com spamd[7004]: server socket setup failed, retry 5: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:04 server.carriechan.com spamd[7004]: server socket setup failed, retry 6: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:05 server.carriechan.com spamd[7004]: server socket setup failed, retry 7: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use

I have search on Google, it is due to IPv6 issues, but I do not have /etc/default/spamassassin file.

May I know how can I do? Many thanks =)

Did you manually install spamassassin?

Did you manually install spamassassin?

Yes, I followed from official article to install (Step 1 to Step 4)

Thanks!

I also tried to use CyberPanel Interface to install Spamassassin
Imgur

But not successful (“SpamAssassin is not installed”)
Imgur

Remove SpamAssassin first from command line,do an upgrade then install from CyberPanel.

Remove SpamAssassin first from command line,do an upgrade then install from CyberPanel.

Yeah, thank you very much! and I can install SpamAssassin on CyberPanel interface. But I see the SpamAssassin status on SSH, it is also shown below message.

May I know is it okay? thanks!

========================================================

[root@carrie ~]# systemctl status spamassassin.service
● spamassassin.service - Spamassassin daemon
Loaded: loaded (/usr/lib/systemd/system/spamassassin.service; disabled; vendor preset: disabled)
Active: activating (start) since 日 2019-04-07 18:39:58 CEST; 6s ago
Process: 7002 ExecStartPre=/sbin/portrelease spamd (code=exited, status=0/SUCCESS)
Control: 7004 (spamd)
CGroup: /system.slice/spamassassin.service
└─7004 /usr/bin/perl -T -w /usr/bin/spamd --pidfile /var/run/spamd.pid -d -c -m5 -H

4月 07 18:39:58 server.carriechan.com systemd[1]: Starting Spamassassin daemon…
4月 07 18:39:59 server.carriechan.com spamd[7004]: server socket setup failed, retry 1: spamd: could not create IO::Socket::IP socket on [::1]:783: Cannot assign requested address
4月 07 18:40:00 server.carriechan.com spamd[7004]: server socket setup failed, retry 2: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use
4月 07 18:40:01 server.carriechan.com spamd[7004]: server socket setup failed, retry 3: spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use

spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use

Port seems to be already in use.

spamd: could not create IO::Socket::IP socket on [127.0.0.1]:783: Address already in use

Port seems to be already in use.

Thank you very much! After I further study, is my Web Hosting set disable_ipv6 as default on CentOS.