Error While Installing Discourse On CyberPanel

I am following this tutorial to install How to install NextCloud on CyberPanel with Docker - CyberPanel

discourse but after attempting all steps I am getting 503 service unavailble error

I used latest image of docker…

I think I misconfigured while following this steps Reverse Proxy Traffic to Docker Container on CyberPanel - CyberPanel

because I dont find this code in conf
extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0
}

so I added this code in conf because I dont find any where to add my port

please help me

When I remove this code from rewritable rules

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

& also

extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0

I am getting normal cyberpanel installed page

guys anyone?

Guyz anyone can point me atleast in right direction

If you read the article you mentioned in your post carefully, it is already explained.

extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0
}

This should go in /usr/local/lsws/conf/httpd_config.conf

And rewrite rules in Rewrite Rules tab

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

All you need to do is read each step in that guide extremely carefully.

Type your comment> @usmannasir said:

If you read the article you mentioned in your post carefully, it is already explained.

extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0
}

This should go in /usr/local/lsws/conf/httpd_config.conf

And rewrite rules in Rewrite Rules tab

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

All you need to do is read each step in that guide extremely carefully.

Thanks for reply
today i did each step carefully but still i am getting 503 service unavailable error

i did indeed change port to 9000…but still getting error…help me with this

heres log

e[38;5;6mdiscourse e[38;5;5m08:44:28.05 e[0m
e[38;5;6mdiscourse e[38;5;5m08:44:28.06 e[0me[1mWelcome to the Bitnami discourse containere[0m
e[38;5;6mdiscourse e[38;5;5m08:44:28.06 e[0mSubscribe to project updates by watching e[1mhttps://github.com/bitnami/bitnami-docker-discoursee[0m
e[38;5;6mdiscourse e[38;5;5m08:44:28.06 e[0mSubmit issues and feature requests at e[1mhttps://github.com/bitnami/bitnami-docker-discourse/issuese[0m
e[38;5;6mdiscourse e[38;5;5m08:44:28.06 e[0m
e[38;5;6mdiscourse e[38;5;5m08:44:28.07 e[0me[38;5;2mINFO e[0m ==> Validating settings in POSTGRESQL_CLIENT_* env vars
e[38;5;6mdiscourse e[38;5;5m08:44:28.13 e[0me[38;5;3mWARN e[0m ==> Hostname postgresql could not be resolved, this could lead to connection issues
e[38;5;6mdiscourse e[38;5;5m08:44:28.15 e[0me[38;5;3mWARN e[0m ==> Hostname redis could not be resolved, this could lead to connection issues
e[38;5;6mdiscourse e[38;5;5m08:44:28.15 e[0me[38;5;3mWARN e[0m ==> The DISCOURSE_DATABASE_PASSWORD environment variable is empty or not set. Set the environment variable ALLOW_EMPTY_PASSWORD=yes to allow a blank password. This is only recommended for development environments.
e[38;5;6mdiscourse e[38;5;5m08:44:28.15 e[0me[38;5;3mWARN e[0m ==> The DISCOURSE_REDIS_PASSWORD environment variable is empty or not set. Set the environment variable ALLOW_EMPTY_PASSWORD=yes to allow a blank password. This is only recommended for development environments.
e[38;5;6mdiscourse e[38;5;5m08:44:28.16 e[0me[38;5;2mINFO e[0m ==> Creating Discourse configuration file
e[38;5;6mdiscourse e[38;5;5m08:44:28.20 e[0me[38;5;2mINFO e[0m ==> Ensuring Discourse directories exist
e[38;5;6mdiscourse e[38;5;5m08:44:28.22 e[0me[38;5;2mINFO e[0m ==> Trying to connect to the database server
e[38;5;6mdiscourse e[38;5;5m08:45:28.44 e[0me[38;5;1mERRORe[0m ==> Could not connect to the database

Type your comment> @usmannasir said:

If you read the article you mentioned in your post carefully, it is already explained.

extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0
}

This should go in /usr/local/lsws/conf/httpd_config.conf

And rewrite rules in Rewrite Rules tab

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

All you need to do is read each step in that guide extremely carefully.

I indeed edit conf via ssh and add rewrite rules by going in the panel…but getting error of 503 error

I know I am just one step behind to get things working…so please help me & point me to right direction

Installing discourse on CyberPanel does not work and I do not recommend it no one will support you. I hope we will be able to set this up in future if discourse allows it.