error when using cyberpanel cli with php exec()

Somebody help me


Any update on this? Plugins which needs php exec does not work with Cyber Panel.
Way to overcome this? We really need php exec with cyberpanel

Your cyberpanel version?

The most updated one 2.3.2
Current Commit : 658b2a1093600056a5bde4c0f356b3ac9a2ec2f5

DISCLAIMER: This may open security issues to your server, so really make sure you need that function.
If you only use it for your own website then should be fine.

Go to:
And remove shell_exec from the disabled_functions

Adjust 7.4 with the version you are editing.

Hello tmoore,

Thanks for the suggestion, I already read this suggestion about the removal of shell_exec value.
The thing is that in CyberPanel for Ubuntu, such value does not exists in php.ini 7.4, only pcntl_exec I can find and I already remove it but still doesn’t work for me.

The odd is that in CyberPanel for Rocky-Linux the values php.ini 7.4 in disable_functions = are nulled!
So in Rocky-Linux the WordPress plugins are working as expected!

So I went back to CyberPanel for Linux and removed ALL the values in disable_functions =
in similar way as for Rocky, but, the plugins still doesn’t work!

So I had the 2 php.ini default files compared (rocky and ubuntu) and I found some key differences …

sendmail_path = /usr/sbin/sendmail -t -i
mysqli.default_socket =
session.gc_probability = 1
disable_functions =

;sendmail_path =
mysqli.default_socket = /var/run/mysqld/mysqld.sock
session.gc_probability = 0
disable_functions = pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wifcontinued,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_get_handler,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,pcntl_async_signals,pcntl_unshare,

So my next move will be to clone Rocky-Linux php.ini to Ubuntu’s and see what happens!



Im using alma, on mine the main php.ini was at that location, as that one looks to be the main php.ini, before the website php.ini settings (the ones you edit at the cyberpanel).

Perhaps at rocky the locations are different (yet should be exactly like alma).

I will install rocky later today to check it out

This were all php.ini that showed up on my system:


With the php error reporting active, it tells you that “shell_exec() been disabled for security reasons” right?

Thanks a lot for investigating this!

The correct php.ini file was in the path you first send me /usr/local/lsws/lsphp74/etc/php/7.4/litespeed/php.ini

I have a similar error message reporting that system cron cannot work so it changes to wordpress cron

The problem is somewhat more cmplex than I thoughted!

In I create a new VPS rocky-linux, restore the files restore the DB and it works!

In I create a new VPS ubuntu-linux, restore the files restore the DB remove the pcntl_exec value from disable_functions = and it works AFTER I re-install the plugin!

In contabo Cloud, I had my primary Ubuntu VPS and it doesn’t work even if I copy the EXACT same php.ini from ubuntu-linux and try to see what happens. Sadly Contabo does not offer hourly charge so I cannot create a new FRESH CyberPanel VPS except if I pay for a whole month!!!

:grimacing: Coming back to report to all of you that it wasn’t php.ini’s fault, and you cannot guess it easily.
It was the Database!!! After I clearly install CyberPanel sometimes I leave it as it is because I forget it, and sometimes I am upgrading the DB from 10.3 which is the default, to 10.8.
And now I get it, after the upgrade, system cron doesn’t work at all.

In Rocky linux I can go until mariadb 10.5 without messing anything but in ubuntu its not the case.
So i will ivestigate a bit deeper and came back!

1 Like

Getting back to this for a final feedback.

Seems that the plugin cannot work with system cron under ubuntu.
Alma and Rocky no problem, I already showed you the difference in php.ini files so it is what is is…