Error installing cyberpanel

i have a problem with the installation of cyberpanel in almalinux when i run the script in the migration process i get the following error

Traceback (most recent call last):
  File “”, line 2626, in <module>.
  File “”, line 2507, in main
    mysqlhost, mysqldb, mysqluser, mysqlpassword, mysqlport)
  File “/root/cyberpanel/install/”, line 806, in Main
  File “/root/cyberpanel/install/install/”, line 369, in installMySQL
    type = clAPVersion.split('-')[0]
AttributeError: 'NoneType' object has no attribute 'split'.
Oops, something went wrong...

the cyberpanel log doesn’t tell me much information.

can you please tell me the exact version of your server os

Happened to mee too now.
AlmaLinux 8

I have the same Issue with AlmaLinux 8.9.


1 Like

it is possible that it is an incompatibility problem with almalinux, with ubuntu the system works fine.

Last week i make an installation on Almalinux 8.9 and go fine, but today not.
something changed in the script.


updated to almalinux 8.10 and the same issue. :smirk:


it is possible that it is because of the file system maybe in almalinux something changed, in ubuntu it works very well in fact the api works excellent better than in almalinux, in ubuntu already comes with python 3.8 unlike almalinux that comes with a different version, at the end I could not find the bug in almalinux… :slight_smile:

And no solutions until today.
Bug devision exist in this company?
Or, they just want use commercial program only?

in almalinux still have not said anything, what I did was to move it to ubuntu and is more stable, the error seems rather repository problems in almalinux

because I had the same problem when installing it, then I tried downgrading cyberpanel to the previous version and it worked.

1 Like

the solution is this, from the linux terminal just run this


and when it asks for the cyberpanel version just put 2.3.5 and the system will take care of the rest.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.