Error: (1364, "Field 'allow_axfr_ips' doesn't have a default value")

I’ve tried to upgrade cyberpanel today. Upgrade was succesfull. But I can’t see pages:
Error: (1364, “Field ‘allow_axfr_ips’ doesn’t have a default value”)

Screenshot 2022-06-05 at 18-22-29 Home - CyberPanel

How can I fix this?

do you have custom packages?

No I don’t. I was using panel without any problem. I saw this error after upgrade.

Is there anyone having same issue?

this is a user account?

No, this is my admin account.

I also had this problem. Any solution?

Hello, at first, make sure you have rebooted the server or any other service that needs restarting after the upgrade.

If the problem persists, this seems to be related to powerDNS. Can you please connect to your server via SSH (e.g. with Putty or WinSCP), locate the PowerDNS directory per your OS, and verify that the /pdns.conf file has the correct values on this specific field? It should be,::1 (as per powerDNS documentation)

1 Like

I’ve already tried theese but not worked.


ok, by “already tried these” you mean that you located powerDNS directory in your server and you verified that the value in pdns.conf is the correct?

If yes, can you please provide any more info? For example:

  1. does the browser console display any errors when visiting Cyberpanel in the front-end?
  2. Can you post any last logs from the server logs files per your OS? (e.g. Access logs, Secure Logs, Server logs, etc.)
  3. Your websites work as they should be and its only the Cyberpanel Home that doesnt work, or other services are down as well?

Any further info would be necessary to dig in. Thanks!

Yes, I’ve rebooted the server and pnds.conf file value is:
# allow-axfr-ips=,::1

Browser console doesn’t show any errors.




And all websites are online and working. Only cyberpanel not working. I see the error that I share on my first post on every cyberpanel page. I can’t access anything on panel:


Hello @reasecret, thanks for the quick response, the detailed info and the useful screenshots.

I just came across to a very helpful post from @usmannasir (Log files on CyberPanel), which explains exactly how to check through CP related logs.

I am sorry for not referring to it in the first place. So, as per the article description, you could try the following:

/***** Starting reference to Usman’s article *****/

CyberPanel Main Log File

CyberPanel’s main log file contains errors related to CyberPanel operations. If something goes wrong directly in CyberPanel this file should be checked

https://<IP Address>:8090/serverstatus/cyberCPMainLogFile

On the server, this file is located at


Improved and detailed dynamic logging


Run command touch /usr/local/CyberCP/debug, this will start generating more debug logs. If you find any issue with CyberPanel, you can run this command and then capture the output of /home/cyberpanel/error-logs.txt

/***** Ending reference to Usman’s article *****/

Can you also investigate the above log files and provide us with more info? Many thanks again!

Sure. But I’ve checked that topic and logs before. This is last error-logs.txt:

Hi again,

hmmm, ok then. Can you try force upgrade again, as per the solution in this post: Error Docker - Manage Images - List index out of range?

*Caution: Please be aware if this is a production environment, I am just trying to help here, not trying to cause further issues.

Sorry for keeping asking simple questions and thanks for answering to all of them but there is no other way of investigating.

Edit: @reasecret Is the Cyberpanel /.git file in the directory specified in the 12-02-18 error or is it missing?

I’ve tried to run upgrade to latest version at first and that not worked. But now, on upgrade console I choose version 1.9.4 and panel is working now. Looks like there is a problem with 1.9.5 version.

And for your edit: There is no git file in home/cyberpanel directory.

Thanks for your effort and help…

1 Like

Hi, thanks a lot for the great cooperation, resource sharing and detailed explanations. I’m glad that you figured it out. One last notice (and sorry if I am missing something): Shouldn’t the latest version be 2.x.x (and not 1.9.5)?

I don’t know exactly whats going on with this version numbers. But on console there was two version numbers 1.9.4 and 1.9.5. As I said I choose 1.9.4 and now version management page looks like this:

Screenshot 2022-06-09 at 22-26-17 Version Management - CyberPanel

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.