Enable Gzip Compression on PHP 7.2 Website

Hi

I am trying to install a custom PHP software & it requires Gzip compression enabled to complete installation. I have enabled Gzip from Cyberpanel admin area in Litespeed tuning but it’s not working.

Also checked in OLS Webconsole at port 7080 and it shows compression enabled.

PHP software shows this error "Warning: Enable Gzip compression for Script to work! | Extension zlib.output_compression "

Can anyone let me know how to install the “zlib.output_compression” extesnsion on CyberPanel v 1.9.1 installtion as it’s not available in current extension list.

@qtwrk @usmannasir Can you please suggest a solution.

Thanks.

create a phpinfo and check the setting

it should be enabled in php.ini

Also checked in OLS Webconsole at port 7080 and it shows compression enabled.

then disable it ? maybe cyberpanel didn’t override it

Hi @qtwrk

I created a phpinfo & it shows the Gzip compression is enabled but the “zlib.output_compression” output is showing as off & Level as -1 check in this image zlib.output_compression - Image on Pasteboard

Any idea how to turn it on. I also turned compression off in OLS web console.

I can message you the site URL in PM let me know.

Thanks

edit php.ini , kill lsphp

How to edit php.ini for specific website do you mean php.ini Override in web console or should I create a new php.ini & kill lsphp for that website.

section “override global php” , steps before that is already done by cyberpanel.